summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 07:50:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 08:33:20 +0200
commit1747de31277d5310d5627b4362e79591f90fda8f (patch)
tree7961ea51e26c3e683c67bdb15833f54f2ae5123c /dev-python/pyspelling
parentdev-python/bitarray: Bump to 2.2.5 (diff)
downloadgentoo-1747de31277d5310d5627b4362e79591f90fda8f.tar.gz
gentoo-1747de31277d5310d5627b4362e79591f90fda8f.tar.bz2
gentoo-1747de31277d5310d5627b4362e79591f90fda8f.zip
dev-python/pyspelling: Bump to 2.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyspelling')
-rw-r--r--dev-python/pyspelling/Manifest1
-rw-r--r--dev-python/pyspelling/pyspelling-2.7.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyspelling/Manifest b/dev-python/pyspelling/Manifest
index 455a601fa854..74bf61f4aef9 100644
--- a/dev-python/pyspelling/Manifest
+++ b/dev-python/pyspelling/Manifest
@@ -1 +1,2 @@
DIST pyspelling-2.7.2.tar.gz 150911 BLAKE2B 813eca2c4bdf377fd7babec376dd2991713db59c66b509c656cb24a314776c2cc360ec9ff884baec6607f27cae3169672746580d3c58abad35dbfe9f605fc51e SHA512 2937c1985ec6f27713275d9f31d3529e35f219df211be0ac9f1ae89d5c92a1e52c51b982291be7bd25375eb6404f52ac0ad893afbe73aada1fb03923dc09f721
+DIST pyspelling-2.7.3.tar.gz 151244 BLAKE2B bdfb40c6f39dc5adcc31691ef75b2582e78e8d0ed800ef0e263f8f98987ce3911650cb08085315c617c185e6ef183a11508fde4608349d0dad435b9f4fe1da98 SHA512 6903b620993933e80dfef320c0218c6372ee37f1db958b489d273aca24dd91bcc86fd12967848b8e31c2d7d458fb5fbfb521f41328c5955a1914f7d552ae7341
diff --git a/dev-python/pyspelling/pyspelling-2.7.3.ebuild b/dev-python/pyspelling/pyspelling-2.7.3.ebuild
new file mode 100644
index 000000000000..73d0ffb19840
--- /dev/null
+++ b/dev-python/pyspelling/pyspelling-2.7.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ ~dev-python/mkdocs_pymdownx_material_extras-1.1.3
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Spell checker automation tool"
+HOMEPAGE="https://github.com/facelessuser/pyspelling"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || ( app-text/aspell app-text/hunspell )
+
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-6.0.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}