summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-16 10:34:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-16 11:00:13 -0500
commit48986735d8a1517a4647033395783f4c5055b43e (patch)
tree46537569f7ee8307f335114adf72efad75aaabb2 /dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
parentdev-python/josepy: add py37 to 1.1.0 (diff)
downloadgentoo-48986735d8a1517a4647033395783f4c5055b43e.tar.gz
gentoo-48986735d8a1517a4647033395783f4c5055b43e.tar.bz2
gentoo-48986735d8a1517a4647033395783f4c5055b43e.zip
dev-python/pyrfc3339: 1.1 bump and py37 support
Bug: https://bugs.gentoo.org/685330 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pyrfc3339/pyrfc3339-1.1.ebuild')
-rw-r--r--dev-python/pyrfc3339/pyrfc3339-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
new file mode 100644
index 000000000000..0d30481718a6
--- /dev/null
+++ b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+inherit distutils-r1
+MY_PN=pyRFC3339
+
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Generates and parses RFC 3339 timestamps"
+HOMEPAGE="https://github.com/kurtraschke/pyRFC3339"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests || die
+}