summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-15 17:17:22 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-16 13:33:39 +0100
commit68d757d5379b7a91d895124b62f8bc5ea724d437 (patch)
tree8f2c2b0165f180c35bd6277b07d39aafbc78c564 /dev-python/pypy3-bin
parentdev-python/pypy-bin: Fix mtimes between generated and source files (diff)
downloadgentoo-68d757d5379b7a91d895124b62f8bc5ea724d437.tar.gz
gentoo-68d757d5379b7a91d895124b62f8bc5ea724d437.tar.bz2
gentoo-68d757d5379b7a91d895124b62f8bc5ea724d437.zip
dev-python/pypy3-bin: Fix mtimes between generated and source files
Ensure to preserve file mtimes while copying them from the source tree to the installation image. This ensures that the generated files are newer than source files, and that PyPy does not attempt to rewrite them at runtime.
Diffstat (limited to 'dev-python/pypy3-bin')
-rw-r--r--dev-python/pypy3-bin/pypy3-bin-5.9.0-r3.ebuild (renamed from dev-python/pypy3-bin/pypy3-bin-5.9.0-r2.ebuild)2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/pypy3-bin/pypy3-bin-5.9.0-r2.ebuild b/dev-python/pypy3-bin/pypy3-bin-5.9.0-r3.ebuild
index 0f0e4bd042db..4ac56798f83a 100644
--- a/dev-python/pypy3-bin/pypy3-bin-5.9.0-r2.ebuild
+++ b/dev-python/pypy3-bin/pypy3-bin-5.9.0-r3.ebuild
@@ -150,6 +150,8 @@ src_install() {
doexe pypy3-c libpypy3-c.so
pax-mark m "${ED%/}${dest}/pypy3-c" "${ED%/}${dest}/libpypy3-c.so"
insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
doins -r include lib_pypy lib-python
dosym ../$(get_libdir)/pypy3/pypy3-c /usr/bin/pypy3
dodoc README.rst