summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-25 05:57:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-25 06:38:55 +0200
commitccfc7367e84ca0d88779dbedd80a985b3b095c65 (patch)
tree11312b097d19e0ba86ac6befeaa16372615ab546 /dev-python/pyparsing
parentdev-python/python-utils: Bump to 3.9.0 (diff)
downloadgentoo-ccfc7367e84ca0d88779dbedd80a985b3b095c65.tar.gz
gentoo-ccfc7367e84ca0d88779dbedd80a985b3b095c65.tar.bz2
gentoo-ccfc7367e84ca0d88779dbedd80a985b3b095c65.zip
dev-python/pyparsing: Bump to 3.2.0_beta2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-3.2.0_beta2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index 132f1aee9f83..46abf4e5575d 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,3 +1,4 @@
DIST pyparsing-3.1.2.tar.gz 889571 BLAKE2B 69dc249c8760470e9611c367255176afcbfdf299b739c8e191f71b88653e0d35db3a20d156ae6507a1748f775b0853c127986d9de2124edc12e22453a75b908d SHA512 1134949f3576edbec4438eefe952eb5cc6e734fb060905d714b6a77f71e90d364b01345df5e7b8fb5ffa798c530be9c65f6d152b3f591cba787660c4dd8894d2
DIST pyparsing-3.1.4.tar.gz 900231 BLAKE2B 121092316528a69f79a8fac5e903de513c4193bd00d5ef7e98dfcb09f3a48eb3384217ede39b0f954f58bdade8644931ce8cef41729539fc1be3dfb910b90be7 SHA512 b475e5571510cd7b07fecbc8ae583b1e75a6308b64018d2884570dfa461e0529b96d02d11403cecac41f92b5d802a5dd4bbf9f8321d58ffa2d24cb89b86652e1
DIST pyparsing-3.2.0b1.tar.gz 907144 BLAKE2B 873f25e8a633fe96587793dc36aae49e6fcb865297cfeea8a47fd431fb9061373db4ad2631f8c581b9e54e417b086c13e3f0364c0895fe22d65935feff7d9a66 SHA512 455bf46414efc850339d62028c478e2f7615eded65415bc15ebcc7319dcac9f1b56257ba1da576cf276e65e40b173e32fd504cbcd0a0b9e5df2e2d906643329e
+DIST pyparsing-3.2.0b2.tar.gz 913100 BLAKE2B 50cb171b9fec23d04ea30b649f98dba605c317ea50a07a94f4391a63fac9f177421a910b3d52010238692ebae4dce0d236f9f32676db1402514dc5d873a4fae1 SHA512 401d80d7ffffb5407d26a80d1638c0c9516bf242d8b3ac0d0947914105a6b42cce355cc52002921103aee7b668042179be43ea3929b2cda9cf21da99aa0f971e
diff --git a/dev-python/pyparsing/pyparsing-3.2.0_beta2.ebuild b/dev-python/pyparsing/pyparsing-3.2.0_beta2.ebuild
new file mode 100644
index 000000000000..bd3fdd7b49b7
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.2.0_beta2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2004-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="
+ https://github.com/pyparsing/pyparsing/
+ https://pypi.org/project/pyparsing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+ )
+ local EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_examples.py::TestExamples::test_range_check
+ tests/test_examples.py::TestExamples::test_rosettacode
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+ )
+
+ if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_matplotlib_cases.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}