summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 20:13:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 21:03:41 +0100
commitbb25cb9d633262dc64655b887c9c481a8144424b (patch)
tree1101c5ac97fa3160e419a25c8c47bcd3bb118d40 /dev-python/pyparsing
parentdev-python/astroid: Bump to 2.8.5 (diff)
downloadgentoo-bb25cb9d633262dc64655b887c9c481a8144424b.tar.gz
gentoo-bb25cb9d633262dc64655b887c9c481a8144424b.tar.bz2
gentoo-bb25cb9d633262dc64655b887c9c481a8144424b.zip
dev-python/pyparsing: Bump to 3.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-3.0.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index cfe378d950f2..e4247371ebab 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -4,3 +4,4 @@ DIST pyparsing_3.0.1.tar.gz 936219 BLAKE2B cc7dc4670f37a09e98c8bda785bac4121150f
DIST pyparsing_3.0.3.tar.gz 938435 BLAKE2B 5237244693759ffc19637b4d8ee52f98b7160160c1f422a1720b9a8848025f37cb8b314aae505acb7696cc1546c495d049a6a93b3824d784b89aee3565001a4a SHA512 19735a3125620716a0a843156e6e9285c7811aa4db876fdc9fed7413dff77c0670fea5a0a16bc074704c6fec45f0129d1a3680b2123abf3c414fa75d73e03d36
DIST pyparsing_3.0.4.tar.gz 939837 BLAKE2B 27130518d1f3a4e497ecd4fa1fc624516bcb62488baf881ae3c8888bca48c957a4c6f0bf8d29aeeca8b1aa907c04ca41f3a61e876b78f1ea50684e24b12a2422 SHA512 01acf9b7663feae57e82ac3139c35687ea2754874425acfcf29b82595977660dab86ec35665e96400eb92acfbb51fb2326e010b960be7570de7575296078bd31
DIST pyparsing_3.0.5.tar.gz 940615 BLAKE2B 7ca78eb4ddd769a49f9538757fc3aae1a1fa11ed1a8fd4483ac80bf50b483e0a8ca5ee13739fbb8c40a6009e3dd48aabab6fbb29fdd01f6f82c11b22348408e1 SHA512 b3efebc911f3c3850ebbb573299a843aab1ca2fb612e41d93947f59ebba9a716ca099b5ec2f9ad8091cb82f6018910205d8409c403f26fb64e72cbb474d05223
+DIST pyparsing_3.0.6.tar.gz 942509 BLAKE2B 1ece2e83dd4193c8364bf690afc54090b46658fced62fc852b0098208d2ae4b18e96f050e63d8751c4b5cf95aa178a11dd1c37fc9d63ae1551639b5c91fe81d8 SHA512 5e94f1dcb4560a0f8e5b9a979b691b6362939648d03e9ea03f74e3aeeddafc09029c8e82c42a517aebe4a0483fd06cac03ae45030e074a40576f9570ed1eb5cc
diff --git a/dev-python/pyparsing/pyparsing-3.0.6.ebuild b/dev-python/pyparsing/pyparsing-3.0.6.ebuild
new file mode 100644
index 000000000000..5e4cb765d6ac
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2004-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S=${WORKDIR}/${PN}-${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}