summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-10 04:24:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-10 04:24:54 +0100
commitfdee83344a0cee7bce48d013e34860b50d4a27c8 (patch)
treec1132938fe22ade27c25c6898b1710c01bdf4718 /dev-python/pyopenssl
parentdev-python/types-docutils: Bump to 0.20.0.20240310 (diff)
downloadgentoo-fdee83344a0cee7bce48d013e34860b50d4a27c8.tar.gz
gentoo-fdee83344a0cee7bce48d013e34860b50d4a27c8.tar.bz2
gentoo-fdee83344a0cee7bce48d013e34860b50d4a27c8.zip
dev-python/pyopenssl: Bump to 24.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest1
-rw-r--r--dev-python/pyopenssl/pyopenssl-24.1.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 4845999aab92..59bb1bcc43ab 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1 +1,2 @@
DIST pyOpenSSL-24.0.0.tar.gz 183238 BLAKE2B 93c75bd323ceb65945fa57a586403c2166b949ce0d4d158b94dc6c40b49373f63e38b0a2cdf2478ab8f6d5d12feeb261324fa13f06040f91b92fffce408d1071 SHA512 32503eeb8b03d9f7dc580c9a2fbbc009a1498b444d17751253bccf8344897408e6d99043dae01385d00bd56fa5aa7d486a43fdc81b1d14cc59fa372c9e58c4e8
+DIST pyOpenSSL-24.1.0.tar.gz 179671 BLAKE2B d49139e9604e854427005adb17cbc8926fa4e10390b36446f9c95dbe81802bb8b97c2e6f1ea8f91dfd74733631292c88536c4f9772647e6d4b449b4d01ed6355 SHA512 acb07025f085d2fe9338e5ce5f65937001b1a8376c41ac532e9b0548668ce05c844e3e28c58efad812a034becf8e24aa9504165ff6af4c3b085cf463fa4d2fb6
diff --git a/dev-python/pyopenssl/pyopenssl-24.1.0.ebuild b/dev-python/pyopenssl/pyopenssl-24.1.0.ebuild
new file mode 100644
index 000000000000..939441d62a86
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-24.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+PYPI_NO_NORMALIZE=1
+PYPI_PN=pyOpenSSL
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ https://www.pyopenssl.org/
+ https://github.com/pyca/pyopenssl/
+ https://pypi.org/project/pyOpenSSL/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/cryptography-43[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-41.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+
+ # test for 32-bit time_t
+ "$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} -c -x c - -o /dev/null <<-EOF &>/dev/null
+ #include <sys/types.h>
+ int test[sizeof(time_t) >= 8 ? 1 : -1];
+ EOF
+
+ if [[ ${?} -eq 0 ]]; then
+ einfo "time_t is at least 64-bit long"
+ else
+ einfo "time_t is smaller than 64 bits, will skip broken tests"
+ EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
+ fi
+
+ distutils-r1_src_test
+}