summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-10 20:24:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-10 20:25:48 +0300
commit5a7890bf0aa8f97a7b22bba0ff4ae71bb5c37601 (patch)
tree63d1c2d1e7052586ea75047923116ea06f1fc499 /dev-python/pymad
parentdev-python/griffe: add 0.36.2 (diff)
downloadgentoo-5a7890bf0aa8f97a7b22bba0ff4ae71bb5c37601.tar.gz
gentoo-5a7890bf0aa8f97a7b22bba0ff4ae71bb5c37601.tar.bz2
gentoo-5a7890bf0aa8f97a7b22bba0ff4ae71bb5c37601.zip
dev-python/pymad: add 0.11.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pymad')
-rw-r--r--dev-python/pymad/Manifest1
-rw-r--r--dev-python/pymad/pymad-0.11.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pymad/Manifest b/dev-python/pymad/Manifest
index 1383c899289f..c948fafeeb33 100644
--- a/dev-python/pymad/Manifest
+++ b/dev-python/pymad/Manifest
@@ -1 +1,2 @@
DIST pymad-0.10.tar.gz 26815 BLAKE2B df694f1fcc7b2c6d0d0aa064b60d061ade2240085867b6a12b3ed63a93cbcac20ac40b3929fbf5b8d9c7b6dbc52883130d02b309ce7690addda6c78813ca2847 SHA512 68a7c93031d174ab50dfa406eec4166be2158d39c4231baee18b7d9c879692376cbf491bcd3e5747e65c496b07a40d1597532551aedcdf05d0fa46f6e185a3d8
+DIST pymad-0.11.3.gh.tar.gz 30098 BLAKE2B 70f93283128319b9849fb53bf5c55526da6236596c44eefa2b050d91aaa6593e1f0196cb4f5d9dc88768ebd1bb05a774b035e251bdd7e1d1b5202326324861e3 SHA512 42d323b75dbdfb307e593548f421f2e387ac487bac2e0539bbc479fad23a79eb64404f5fc2d3146e687c0f9fab39dfffd2a2b890b070baf41fdcb06032f90770
diff --git a/dev-python/pymad/pymad-0.11.3.ebuild b/dev-python/pymad/pymad-0.11.3.ebuild
new file mode 100644
index 000000000000..cbe33b036628
--- /dev/null
+++ b/dev-python/pymad/pymad-0.11.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for libmad MP3 decoding in python"
+HOMEPAGE="
+ https://github.com/jaqx0r/pymad/
+ https://pypi.org/project/pymad/
+"
+SRC_URI="
+ https://github.com/jaqx0r/pymad/releases/download/v${PV}/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="media-libs/libmad"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest