summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-25 13:35:56 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-25 13:41:02 +0200
commit4e7aa931a2fac2dd59ebaaf48c936cffd52340c1 (patch)
tree77521b42dd190d65acbb05f1c1cc9344ca06efe8 /dev-python/pylama
parentdev-perl/JSON-Parse: x86 stable wrt bug #810115 (diff)
downloadgentoo-4e7aa931a2fac2dd59ebaaf48c936cffd52340c1.tar.gz
gentoo-4e7aa931a2fac2dd59ebaaf48c936cffd52340c1.tar.bz2
gentoo-4e7aa931a2fac2dd59ebaaf48c936cffd52340c1.zip
dev-python/pylama: enable py3.10, epytest, fix setuptools dep.
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pylama')
-rw-r--r--dev-python/pylama/pylama-7.7.1-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/pylama/pylama-7.7.1-r1.ebuild b/dev-python/pylama/pylama-7.7.1-r1.ebuild
index 3bc25306acac..a7fb5370fb22 100644
--- a/dev-python/pylama/pylama-7.7.1-r1.ebuild
+++ b/dev-python/pylama/pylama-7.7.1-r1.ebuild
@@ -3,8 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -41,8 +40,10 @@ python_prepare_all() {
}
python_test() {
- # Disable eradicate until it is fixed:
- # https://github.com/klen/pylama/issues/190
- pytest -vv tests --deselect tests/test_linters.py::test_eradicate \
- || die "Tests failed with ${EPYTHON}"
+ local EPYTEST_DESELECT=(
+ # Disable eradicate until it is fixed:
+ # https://github.com/klen/pylama/issues/190
+ tests/test_linters.py::test_eradicate
+ )
+ epytest tests
}