summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-26 08:22:24 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-28 16:19:18 +0200
commit28777e293be79d91f05305f4104ba61d0fd75422 (patch)
tree90732c6b955b5369921fdab581bb1c0a771e92e3 /dev-python/pycdio
parentwww-client/firefox: bump to v89.0 RC 2 (diff)
downloadgentoo-28777e293be79d91f05305f4104ba61d0fd75422.tar.gz
gentoo-28777e293be79d91f05305f4104ba61d0fd75422.tar.bz2
gentoo-28777e293be79d91f05305f4104ba61d0fd75422.zip
dev-python/pycdio: bump to python 3.{9,10}, enable tests
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/pycdio-2.1.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pycdio/pycdio-2.1.0.ebuild b/dev-python/pycdio/pycdio-2.1.0.ebuild
index 827ab2874412..5652e3e6c98c 100644
--- a/dev-python/pycdio/pycdio-2.1.0.ebuild
+++ b/dev-python/pycdio/pycdio-2.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
@@ -19,6 +19,8 @@ BDEPEND="dev-lang/swig"
RDEPEND=">=dev-libs/libcdio-2.0.0"
DEPEND="${RDEPEND}"
+distutils_enable_tests nose
+
python_prepare_all() {
# Remove obsolete sys.path and adjust 'data' paths in examples.
sed -i \