summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-18 12:15:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-18 12:15:10 +0100
commit20817c46200f4e28cc68dedea3d5a6806ea54cbc (patch)
treebd42032add03e7e958f129941a18b3db3d97e142 /dev-python/pycapnp/pycapnp-0.6.3.ebuild
parentsys-cluster/keepalived: fix segfault when no sorry server is configured (diff)
downloadgentoo-20817c46200f4e28cc68dedea3d5a6806ea54cbc.tar.gz
gentoo-20817c46200f4e28cc68dedea3d5a6806ea54cbc.tar.bz2
gentoo-20817c46200f4e28cc68dedea3d5a6806ea54cbc.zip
dev-python/pycapnp: bump to 0.6.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/pycapnp/pycapnp-0.6.3.ebuild')
-rw-r--r--dev-python/pycapnp/pycapnp-0.6.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycapnp/pycapnp-0.6.3.ebuild b/dev-python/pycapnp/pycapnp-0.6.3.ebuild
new file mode 100644
index 000000000000..d6460a75c2ca
--- /dev/null
+++ b/dev-python/pycapnp/pycapnp-0.6.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapping of the Cap'n Proto library"
+HOMEPAGE="http://jparyani.github.io/pycapnp/ https://github.com/capnproto/pycapnp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND=">=dev-libs/capnproto-0.6:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # regen cython files
+ rm -f capnp/lib/capnp.cpp || die
+}