summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 22:13:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 22:13:55 +0100
commit187f42feb48e159c00337e766e29b11bd6e685e9 (patch)
tree7742e1acdd63b10628bf0deb900dc3c34ce85835 /dev-python/pyGPG
parentdev-python/pydecomp: Switch to PEP 517 build (diff)
downloadgentoo-187f42feb48e159c00337e766e29b11bd6e685e9.tar.gz
gentoo-187f42feb48e159c00337e766e29b11bd6e685e9.tar.bz2
gentoo-187f42feb48e159c00337e766e29b11bd6e685e9.zip
dev-python/pyGPG: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyGPG')
-rw-r--r--dev-python/pyGPG/pyGPG-0.2-r1.ebuild44
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild25
2 files changed, 56 insertions, 13 deletions
diff --git a/dev-python/pyGPG/pyGPG-0.2-r1.ebuild b/dev-python/pyGPG/pyGPG-0.2-r1.ebuild
new file mode 100644
index 000000000000..1649f810972a
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ elog
+ elog "This is experimental software."
+ elog "The API's it installs should be considered unstable"
+ elog "and are subject to change."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/pyGPG/issues"
+ elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+ elog
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
index fc4ad1900dce..1649f810972a 100644
--- a/dev-python/pyGPG/pyGPG-9999.ebuild
+++ b/dev-python/pyGPG/pyGPG-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=no
-
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
@@ -31,15 +30,15 @@ RDEPEND="${DEPEND}
"
pkg_postinst() {
- einfo
- einfo "This is experimental software."
- einfo "The API's it installs should be considered unstable"
- einfo "and are subject to change."
- einfo
- einfo "Please file any enhancement requests, or bugs"
- einfo "at https://github.com/dol-sen/pyGPG/issues"
- einfo "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
- einfo
+ elog
+ elog "This is experimental software."
+ elog "The API's it installs should be considered unstable"
+ elog "and are subject to change."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/pyGPG/issues"
+ elog "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+ elog
ewarn "There may be some python 3 compatibility issues still."
ewarn "Please help debug/fix/report them in github or bugzilla."
}