summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 04:40:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 05:14:27 +0200
commit75bfcb44a15308f3ef63fe8a537f3dc4109e3e28 (patch)
treeba1eab86232d16dc191ffaed31ced4ffb02ec5a5 /dev-python/prettytable
parentdev-python/loguru: Bump to 0.7.0 (diff)
downloadgentoo-75bfcb44a15308f3ef63fe8a537f3dc4109e3e28.tar.gz
gentoo-75bfcb44a15308f3ef63fe8a537f3dc4109e3e28.tar.bz2
gentoo-75bfcb44a15308f3ef63fe8a537f3dc4109e3e28.zip
dev-python/prettytable: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 843f93bcebf7..d18e987ed668 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,2 +1,3 @@
DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
DIST prettytable-3.6.0.gh.tar.gz 46174 BLAKE2B 2a7e507efdf4ab3282e95e8db14b92477fdd40a06fdb009146ce6a3a52ef49e46a61803ac3cd85d2ec993ad8cc49bd842d438b97fc037e56cb33cd4495b535ef SHA512 b4693a3d30555f598cb955923560d02ce7c757e87ee49bf09c8d50d3ce8bef67ebfad1c780914f488e89852c0e363c2cad098addc058a88864efb8eefa8e9cd8
+DIST prettytable-3.7.0.gh.tar.gz 46706 BLAKE2B bf9626b3427b4dfaf23d504dfae82b67d581c87580de7ac6209162a26c67dd3f760848b6f8808384b4cb115b6e44aa3f5ac3321806c8c035abd6826614ad321b SHA512 5411bf700e0046a63ebbea7575e5617d2045cc409a00d8d6e2362d96d4ec514cd6e815132dc0b80fe864a862c329e7f1606f5e55a4bf014b0ec9d690b57e6783
diff --git a/dev-python/prettytable/prettytable-3.7.0.ebuild b/dev-python/prettytable/prettytable-3.7.0.ebuild
new file mode 100644
index 000000000000..60c7957b7724
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+SRC_URI="
+ https://github.com/jazzband/prettytable/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}