summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 06:44:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 06:44:05 +0200
commitd896325497e31c2d512efe96f7d9cfa82082ce08 (patch)
tree1090c088106fe0b1152eb70c461bcf89b082a25b /dev-python/portend
parentapp-admin/awscli: Bump to 1.27.162 (diff)
downloadgentoo-d896325497e31c2d512efe96f7d9cfa82082ce08.tar.gz
gentoo-d896325497e31c2d512efe96f7d9cfa82082ce08.tar.bz2
gentoo-d896325497e31c2d512efe96f7d9cfa82082ce08.zip
dev-python/portend: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/portend')
-rw-r--r--dev-python/portend/Manifest1
-rw-r--r--dev-python/portend/portend-3.2.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/portend/Manifest b/dev-python/portend/Manifest
index c553c8574848..0cbe8a6406cb 100644
--- a/dev-python/portend/Manifest
+++ b/dev-python/portend/Manifest
@@ -1 +1,2 @@
DIST portend-3.1.0.tar.gz 9448 BLAKE2B d9391577ecc6f878ebbceb07266f06902352076fb61164b5e905a3ed0a557ce5dafcd8e3c77a099aab97fa576aee5be024d98f457e3b333aa80dbd534167218b SHA512 017dff68ea85f48d19398f71fbd8189329ca9c27c05d8599dd5e53632eb5ddc6dea322e94c924a0653f25f042a3c8ee1cda5f8450b02f3406a72036d54cd1aaf
+DIST portend-3.2.0.tar.gz 10514 BLAKE2B f60a800d37e61400e173507146f33ed6977cb0020773f5d2b6fba0a155bfd7e101e00bf057604ec0f25f5cd6f1bb57e3bfe2fc2bbe75b00f55c234f597a1f3f6 SHA512 56790cdb6d1619e8873acc2498f9bee758a64ad8f8e47f31e48ae1ac7b6f038fc81af5d52cbc4bc4797dd6dc25d453d391d73d454c98559b1d6a8e9061837d7f
diff --git a/dev-python/portend/portend-3.2.0.ebuild b/dev-python/portend/portend-3.2.0.ebuild
new file mode 100644
index 000000000000..c0a7eef39857
--- /dev/null
+++ b/dev-python/portend/portend-3.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="
+ https://github.com/jaraco/portend/
+ https://pypi.org/project/portend/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/tempora-1.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest