summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-14 05:15:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-14 05:15:28 +0200
commitcc5bfbbee347c46037d1cd8159c134bd857903b6 (patch)
tree34d042cdf0e2e8b253628e233cc3e0c0daafe487 /dev-python/portalocker
parentdev-python/hypothesis: Bump to 6.108.0 (diff)
downloadgentoo-cc5bfbbee347c46037d1cd8159c134bd857903b6.tar.gz
gentoo-cc5bfbbee347c46037d1cd8159c134bd857903b6.tar.bz2
gentoo-cc5bfbbee347c46037d1cd8159c134bd857903b6.zip
dev-python/portalocker: Bump to 2.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/portalocker')
-rw-r--r--dev-python/portalocker/Manifest1
-rw-r--r--dev-python/portalocker/portalocker-2.10.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/portalocker/Manifest b/dev-python/portalocker/Manifest
index 659490fb5de7..38ebd4207f9f 100644
--- a/dev-python/portalocker/Manifest
+++ b/dev-python/portalocker/Manifest
@@ -1 +1,2 @@
DIST portalocker-2.10.0.gh.tar.gz 34084 BLAKE2B 9efb130859002a4a6bb4c18b2fad293b6cfe3344402b7442be4d4d1b17ff837ff45a39ebb5e50db09ce2dcc7c902b72fa9d9f64625e772be1150d5659f2eafaa SHA512 79b60472ca589e6e696203f829eae2d66c11fca4ee2c7280aad91395f2cc2db6a1c7ae131d7a4945b2a2455ad62829a8a3163c628a74ec46a0f1564ea27d50e7
+DIST portalocker-2.10.1.gh.tar.gz 34084 BLAKE2B c4b8b0f42e25c28dd73f73459f2425a355c1be7fb6d9e601c8f829b76a421b66981c96d948513a92b0d9746f0d4b4c9423eb671e160629d421b6720bb3c81883 SHA512 cdb5db6eab2974a8fef5628656b9e66bd1907d3010e28071c5a308d52a7ad28f838f3cb90e8bc258b2f258b8b999438e90972751e4d29b1769056db4f9ab9f8b
diff --git a/dev-python/portalocker/portalocker-2.10.1.ebuild b/dev-python/portalocker/portalocker-2.10.1.ebuild
new file mode 100644
index 000000000000..1981e8b48083
--- /dev/null
+++ b/dev-python/portalocker/portalocker-2.10.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A library for Python file locking"
+HOMEPAGE="
+ https://github.com/WoLpH/portalocker/
+ https://portalocker.readthedocs.io/
+ https://pypi.org/project/portalocker/
+"
+SRC_URI="
+ https://github.com/WoLpH/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/redis[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # Disable code coverage in tests.
+ sed -i '/^ *--cov.*$/d' pytest.ini || die
+}
+
+pkg_postinst() {
+ optfeature "redis support" dev-python/redis
+}