summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-28 17:10:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-28 17:18:52 +0100
commite7465e8f5d8090b2463e7358d92e94bd091709c3 (patch)
tree35c964400df9a6498272b257aac1ece56c6b2de6 /dev-python/poetry-core
parentdev-python/fritzconnection: Bump to 1.11.0 (diff)
downloadgentoo-e7465e8f5d8090b2463e7358d92e94bd091709c3.tar.gz
gentoo-e7465e8f5d8090b2463e7358d92e94bd091709c3.tar.bz2
gentoo-e7465e8f5d8090b2463e7358d92e94bd091709c3.zip
dev-python/poetry-core: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest1
-rw-r--r--dev-python/poetry-core/poetry-core-1.5.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index 76f6257ddfc9..589d23cd8318 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1 +1,2 @@
DIST poetry-core-1.4.0.gh.tar.gz 556575 BLAKE2B 6a0860f965bb7d554f1f13c46d76727b9a763dd3dc04a1d889ca894c30ad91e46931308981560fadf70348731f080322da9c9590248b7877e02eb81f4009e02a SHA512 31c9b42ae8e4ec5c4cec93604a5ea72642fb89717867d7f43fdf930835c7e1da97b0251870d86841c30b1bf0ee7b167fc6a8dcfe939beb5b40acd7e24dfaede7
+DIST poetry-core-1.5.0.gh.tar.gz 478924 BLAKE2B 54653b6a8dcac08ac732ccb8efd2ff0404e6e78e7e2f6981fca2aafc53144309372389cc11d2524470ff25b0fc3ade5039df850629fefe016b6e9860f09d3247 SHA512 18b62096f32b7e57abc296bd8e35d0802873563c83e19b0e6e5f9994edaa503e05b9a782a6612d28b8544e34efc92efe213dcd5b595ec1d217e678522df3ae31
diff --git a/dev-python/poetry-core/poetry-core-1.5.0.ebuild b/dev-python/poetry-core/poetry-core-1.5.0.ebuild
new file mode 100644
index 000000000000..3662767312e7
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.5.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="
+ https://github.com/python-poetry/poetry-core/
+ https://pypi.org/project/poetry-core/
+"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# check inside src/poetry/core/_vendor/vendor.txt
+# (note that some are indirect deps)
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pep517[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r src/poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # needed for migration from <1.1
+ distutils_write_namespace poetry
+ epytest
+}