summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-06 04:28:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-06 04:30:48 +0200
commite6d6b52f8085ae14726e51a0f4ce4879e14bd282 (patch)
tree20926dd4aad771ede5ac3b6392e7ee329bf51fde /dev-python/plumbum
parentdev-python/humanize: Bump to 4.11.0 (diff)
downloadgentoo-e6d6b52f8085ae14726e51a0f4ce4879e14bd282.tar.gz
gentoo-e6d6b52f8085ae14726e51a0f4ce4879e14bd282.tar.bz2
gentoo-e6d6b52f8085ae14726e51a0f4ce4879e14bd282.zip
dev-python/plumbum: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest1
-rw-r--r--dev-python/plumbum/plumbum-1.9.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index 793249a2033a..52e639471764 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1 +1,2 @@
DIST plumbum-1.8.3.tar.gz 318895 BLAKE2B 7c3df70e5bcaf5dfd9c6898f0d2044c647f08a4eaa0eb6bcb616c9971edfc20aa7651dc70a193e06c1d1f97b155a86a6d93d14622ff40da1328b1aa0e6534e6b SHA512 e59dd98939739636c3f1541e24f3c5a4b0c9bbe54b77d378875a57f167ca1916adbca6b33c7779d37e5daebd949c9a9d77bfffc404e55d319027658b5a504088
+DIST plumbum-1.9.0.tar.gz 319083 BLAKE2B eb155511c3726b7b7e564da05ab58294ffdbe9806599d8adbd0a05ffc9cf096a6c551f5d1ef0b9a781a13435e47a6598c90c04d90c852f8536c665d2bfbb58d9 SHA512 afa0436e19ddea192ac7d33a3cdede6a86c801288d6678c9d9daa110ea049b14bc388fe4eb27e172d66595de282648b966043bed8f4c282350753afdf38e14de
diff --git a/dev-python/plumbum/plumbum-1.9.0.ebuild b/dev-python/plumbum/plumbum-1.9.0.ebuild
new file mode 100644
index 000000000000..feaba73825a3
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="
+ https://plumbum.readthedocs.io/en/latest/
+ https://github.com/tomerfiliba/plumbum/
+ https://pypi.org/project/plumbum/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p pytest_mock -p timeout
+}
+
+pkg_postinst() {
+ optfeature "remote commands via ssh" dev-python/paramiko
+ optfeature "progress bars in jupyter" dev-python/ipywidgets
+ optfeature "colored output in jupyter" dev-python/ipython
+ optfeature "images on the command line" dev-python/pillow
+}