summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-22 19:55:00 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-22 23:18:14 +0000
commitb17c791c1cefa856526f78369722808876f42735 (patch)
treef72ba68c299343e7d6ad752fd237f5d917d0d8f6 /dev-python/plotly/plotly-1.9.6.ebuild
parentdev-python/dill: initial import (diff)
downloadgentoo-b17c791c1cefa856526f78369722808876f42735.tar.gz
gentoo-b17c791c1cefa856526f78369722808876f42735.tar.bz2
gentoo-b17c791c1cefa856526f78369722808876f42735.zip
dev-python/plotly: initial import
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/plotly/plotly-1.9.6.ebuild')
-rw-r--r--dev-python/plotly/plotly-1.9.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/plotly/plotly-1.9.6.ebuild b/dev-python/plotly/plotly-1.9.6.ebuild
new file mode 100644
index 000000000000..3b4bc72dc3ce
--- /dev/null
+++ b/dev-python/plotly/plotly-1.9.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"