summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-18 07:26:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-18 08:47:12 +0200
commit24551614446a0b1eb97ff3510d8fc1b87da0de5b (patch)
treed6c47fabcc89ee825511dbb4f7de84f8127edc93 /dev-python/peewee
parentdev-python/boltons: Enable pypy3 (diff)
downloadgentoo-24551614446a0b1eb97ff3510d8fc1b87da0de5b.tar.gz
gentoo-24551614446a0b1eb97ff3510d8fc1b87da0de5b.tar.bz2
gentoo-24551614446a0b1eb97ff3510d8fc1b87da0de5b.zip
dev-python/peewee: Bump to 3.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.15.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index e51343887c3d..07470d60107a 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1 +1,2 @@
DIST peewee-3.14.10.tar.gz 896121 BLAKE2B c6d42dbca418475325e704e86dbf1d420426b1276a63ad1d49f3361478325b5a4b01bcbd875b32439bb497c4e18248efa6fe44c589c3247ee84043ca1bfc1a74 SHA512 1f423097c67c6a3976ed77586e3ea9db6db42e3c18e6f4c6046176a0e8942a9ce228cefd2a09e39fde359479e70a04e4c06030682442d96657d24984666b13d1
+DIST peewee-3.15.0.gh.tar.gz 903961 BLAKE2B d3e01171fb281c1b371bc6518366fec698144761d1a88da25200b8a68ab909ca195c7900cc9f7439456ac14472f4b611cdd6ffb512e2448192cb892fb514cc62 SHA512 63c7a765327aa89ec0cb1d6306fa121f25fba39c353b475d6be4c59a2f8cf99724c366a314c769dc78e3da453c888d48d4d6151647af1621cfa16aade7118e25
diff --git a/dev-python/peewee/peewee-3.15.0.ebuild b/dev-python/peewee/peewee-3.15.0.ebuild
new file mode 100644
index 000000000000..07b7c4995d4d
--- /dev/null
+++ b/dev-python/peewee/peewee-3.15.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="
+ https://github.com/coleifer/peewee/
+ https://pypi.org/project/peewee/
+"
+SRC_URI="
+ https://github.com/coleifer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}