summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-24 14:29:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-25 10:00:35 +0300
commited596ce1f08c66020938f6602fdc7179cc161835 (patch)
tree0e590c0d812c170735986a0d9ba8127a3c547421 /dev-python/patiencediff/patiencediff-0.2.2.ebuild
parentmedia-sound/terminatorx: fixed fetching issue with 4.1.0 (diff)
downloadgentoo-ed596ce1f08c66020938f6602fdc7179cc161835.tar.gz
gentoo-ed596ce1f08c66020938f6602fdc7179cc161835.tar.bz2
gentoo-ed596ce1f08c66020938f6602fdc7179cc161835.zip
dev-python/patiencediff: intial import (NIG dep of dev-vcs/breezy)
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/patiencediff/patiencediff-0.2.2.ebuild')
-rw-r--r--dev-python/patiencediff/patiencediff-0.2.2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/patiencediff/patiencediff-0.2.2.ebuild b/dev-python/patiencediff/patiencediff-0.2.2.ebuild
new file mode 100644
index 000000000000..917b4b785ddb
--- /dev/null
+++ b/dev-python/patiencediff/patiencediff-0.2.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the patiencediff algorithm"
+HOMEPAGE="https://pypi.org/project/patiencediff/ https://github.com/breezy-team/patiencediff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest