summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 09:04:40 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commit9a4bce91be9b86494a3e7ebbb7add1163e36a3d0 (patch)
treeabc5dba7b65158360b9ce536a37bd9a56bc36ca5 /dev-python/oslo-sphinx
parentdev-python/oslo-serialization: Add python3.5 support (diff)
downloadgentoo-9a4bce91be9b86494a3e7ebbb7add1163e36a3d0.tar.gz
gentoo-9a4bce91be9b86494a3e7ebbb7add1163e36a3d0.tar.bz2
gentoo-9a4bce91be9b86494a3e7ebbb7add1163e36a3d0.zip
dev-python/oslo-sphinx: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/oslo-sphinx')
-rw-r--r--dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild6
-rw-r--r--dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild b/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild
index d605f8c88dba..f0391516ec80 100644
--- a/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild
+++ b/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
@@ -12,7 +13,6 @@ MY_PN="${PN//-/}"
DESCRIPTION="OpenStack Sphinx Extensions"
HOMEPAGE="http://www.openstack.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -30,3 +30,5 @@ RDEPEND="
>=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
!~dev-python/requests-2.4.0[${PYTHON_USEDEP}]
"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild b/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild
index 2c0859e82f18..69ef325a75e3 100644
--- a/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild
+++ b/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
@@ -12,7 +13,6 @@ MY_PN="${PN//-/}"
DESCRIPTION="OpenStack Sphinx Extensions and Theme"
HOMEPAGE="http://www.openstack.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -31,6 +31,8 @@ DEPEND="
"
RDEPEND=">=dev-python/requests-2.5.2[${PYTHON_USEDEP}]"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
python_compile_all() {
use doc && esetup.py build_sphinx
}