summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-12 06:21:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-12 07:13:45 +0100
commitb292349b23cb2df6a3646b2b7e0907d3736d95ac (patch)
tree5c8c962b2e673f49011ccb6041c388f847a047b3 /dev-python/openapi-schema-validator
parentapp-admin/awscli: Bump to 1.27.48 (diff)
downloadgentoo-b292349b23cb2df6a3646b2b7e0907d3736d95ac.tar.gz
gentoo-b292349b23cb2df6a3646b2b7e0907d3736d95ac.tar.bz2
gentoo-b292349b23cb2df6a3646b2b7e0907d3736d95ac.zip
dev-python/openapi-schema-validator: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-schema-validator')
-rw-r--r--dev-python/openapi-schema-validator/Manifest1
-rw-r--r--dev-python/openapi-schema-validator/openapi-schema-validator-0.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/openapi-schema-validator/Manifest b/dev-python/openapi-schema-validator/Manifest
index dbf6da6615bb..601d07df3a43 100644
--- a/dev-python/openapi-schema-validator/Manifest
+++ b/dev-python/openapi-schema-validator/Manifest
@@ -1,2 +1,3 @@
DIST openapi-schema-validator-0.2.3.gh.tar.gz 25501 BLAKE2B d961cabca647f59d4d4188f1941ce5b2475e02520bcc10e7cd29817c8ea8ebaaac5af1ffb0e3d5079ed2d1493414cdaf55336744b142385754585e748af8ac98 SHA512 e6dfe3d6cc99fa9723102ced42040203157639be68b0438d7bfae4499e51cdb6257a36dca10425a5d5e692cebb958468ebeee722116b99d800a6fcf972400c66
DIST openapi-schema-validator-0.3.4.gh.tar.gz 16593 BLAKE2B 17882dff25d1bed05efa74792930a357d82cb404bbf746a6f348e9813b4af86842da1523a8e3dfaec1426c82efff6b0bddbfca89c8569ba36a4324ab4e5a418b SHA512 714f93594c875a04194a6980dc5e092866609787e424ef480d42da93c114e3b658a5efef13f78ed3db35f6e7399d7dda8adbc1d3bb8606512aa4f135edeaeb75
+DIST openapi-schema-validator-0.4.0.gh.tar.gz 17070 BLAKE2B 199476dd660ab3493fe9805dc915c42f05b2bc5ca0f1f9728aa1e5afe5a923e3f84d82511572e353ab19c15b3094460dcfbde5ef1d96ca834c1da24314223046 SHA512 ce61c112c528bac022e3feb959bfe5adbac000ec0b4956f678bf61f66efdbf3a5cf912a4dfa1512858b497fdadaf533532f5a580f28f6ceea831e6b5ac98d85e
diff --git a/dev-python/openapi-schema-validator/openapi-schema-validator-0.4.0.ebuild b/dev-python/openapi-schema-validator/openapi-schema-validator-0.4.0.ebuild
new file mode 100644
index 000000000000..142ee65dcccb
--- /dev/null
+++ b/dev-python/openapi-schema-validator/openapi-schema-validator-0.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI schema validation for Python"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-schema-validator/
+ https://pypi.org/project/openapi-schema-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-schema-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}