summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 08:15:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 08:19:13 +0200
commitfd837162c0f79967f8de018e997131a1674088b8 (patch)
treef8028c88a3bcccb1e798888148778a4ea1e41c93 /dev-python/olefile
parentdev-python/sqlalchemy: Remove old (diff)
downloadgentoo-fd837162c0f79967f8de018e997131a1674088b8.tar.gz
gentoo-fd837162c0f79967f8de018e997131a1674088b8.tar.bz2
gentoo-fd837162c0f79967f8de018e997131a1674088b8.zip
dev-python/olefile: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/olefile')
-rw-r--r--dev-python/olefile/olefile-0.46-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/olefile/olefile-0.46-r2.ebuild b/dev-python/olefile/olefile-0.46-r2.ebuild
new file mode 100644
index 000000000000..13f3f1d4b42f
--- /dev/null
+++ b/dev-python/olefile/olefile-0.46-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="
+ https://www.decalage.info/olefile/
+ https://github.com/decalage2/olefile/
+ https://pypi.org/project/olefile/
+"
+SRC_URI="
+ https://github.com/decalage2/olefile/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests unittest