summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-16 09:53:07 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-16 10:53:42 +0200
commit366587f522f9158cd7612877d42a807087b2fe1c (patch)
tree0c1a20a8900812e2b513217084607cb78004782e /dev-python/nose-exclude/nose-exclude-0.4.1.ebuild
parentdev-python/pytest: Version Bump (diff)
downloadgentoo-366587f522f9158cd7612877d42a807087b2fe1c.tar.gz
gentoo-366587f522f9158cd7612877d42a807087b2fe1c.tar.bz2
gentoo-366587f522f9158cd7612877d42a807087b2fe1c.zip
dev-python/nose-exclude: Version Bump
Fix HOMEPAGE Enable test for python2 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/nose-exclude/nose-exclude-0.4.1.ebuild')
-rw-r--r--dev-python/nose-exclude/nose-exclude-0.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild b/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild
new file mode 100644
index 000000000000..09afe293eb69
--- /dev/null
+++ b/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Exclude specific directories from nosetests runs"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+ # https://github.com/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+ python_is_python3 && return
+ esetup.py test
+}