summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-23 06:59:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-23 08:16:12 +0200
commit59e40501edaee4e318397f21815fc57250fe5aac (patch)
treeba558e6ed24dfb149854d9631b9b0cdf2d01cf10 /dev-python/mypy
parentapp-admin/awscli: Bump to 1.35.12 (diff)
downloadgentoo-59e40501edaee4e318397f21815fc57250fe5aac.tar.gz
gentoo-59e40501edaee4e318397f21815fc57250fe5aac.tar.bz2
gentoo-59e40501edaee4e318397f21815fc57250fe5aac.zip
dev-python/mypy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-1.12.0.ebuild119
2 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index da063a0ce668..14af6d1ee15b 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,2 @@
DIST mypy-1.11.2.gh.tar.gz 3122502 BLAKE2B 228127662f4c607aacf3ee37410d0fa039a225fdbf2fec27eefab4aaabf4b68fa33499bb978aa5f06e24b45b525ce524decfa84f4d7d6bb7961724db92a4589b SHA512 c25584db08adcf7693944e5a6a41743101e80a0ff03f36f0353a07674ad4e2d63dbd4ff3fa0e307c19d63bc5aac9f7523340bd5a7cb3661642f3fb33759aafd0
-DIST mypy-1.12.0.gh.tar.gz 3163109 BLAKE2B d532d60117f29da66e8c29d3532b3c325cf0cbce04ba075fa949bb734a36e1929d67ce804618dce09fac4dba990970900560365755d95e3a388755da5bdd8cff SHA512 7720b9625dcb30482993162468366596dad2245ee5113c2f3cd7a8175941d339eadbba05a9dd8c8cba3fbed1e3c6ecbcd8c58965c5b585bad1870e401279e656
DIST mypy-1.12.1.gh.tar.gz 3163509 BLAKE2B 7a837b0badcc4fbcd1838cbd85bb46311a3bb1365d08d1704d19c58b840ef0f951fa993484da2933f953c3e7eefa8756c12a6a42b09b369aa55c0a361cb4039d SHA512 c712e2d4824ec5e6348d223225f4055556d0964340d4ec8941a735ece4fc4aa964aa8f02be038fe4b88cd162f6d6377c1ae6897cb6c2449d1820ce20978e1252
diff --git a/dev-python/mypy/mypy-1.12.0.ebuild b/dev-python/mypy/mypy-1.12.0.ebuild
deleted file mode 100644
index 0f181ed2e8ed..000000000000
--- a/dev-python/mypy/mypy-1.12.0.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="
- https://www.mypy-lang.org/
- https://github.com/python/mypy/
- https://pypi.org/project/mypy/
-"
-SRC_URI="
- https://github.com/python/mypy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
-IUSE="+native-extensions"
-
-# stubgen collides with this package: https://bugs.gentoo.org/585594
-RDEPEND="
- !dev-util/stubgen
- >=dev-python/psutil-4[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.6.0[${PYTHON_USEDEP}]
- >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- native-extensions? (
- ${RDEPEND}
- dev-python/types-psutil[${PYTHON_USEDEP}]
- dev-python/types-setuptools[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.9.1[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-# frustratingly, mypyc produces non-deterministic output. If ccache is enabled it will be a waste of time,
-# but simultaneously it might trash your system and fill up the cache with a giant wave of non-reproducible
-# test files (https://github.com/mypyc/mypyc/issues/1014)
-export CCACHE_DISABLE=1
-
-python_compile() {
- local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
- case ${EPYTHON} in
- python3.13)
- # https://github.com/mypyc/mypyc/issues/1056
- MYPY_USE_MYPYC=0
- ;;
- esac
- distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # the majority of them require Internet (via pip)
- mypy/test/testpep561.py
- # known broken with assertions enabled
- # https://github.com/python/mypy/issues/16043
- mypyc/test/test_run.py::TestRun::run-i64.test::testI64GlueMethodsAndInheritance
- mypyc/test/test_run.py::TestRun::run-floats.test::testFloatOps
- # these assume that types-docutils are not installed
- mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testIgnoreImportIfNoPython3StubAvailable
- mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testNoPython3StubAvailable
- # TODO
- mypy/test/meta/test_parse_data.py
- mypy/test/meta/test_update_data.py
- )
- case ${EPYTHON} in
- python3.13)
- ;&
- python3.12)
- EPYTEST_DESELECT+=(
- # more assertions, sigh
- mypyc/test/test_run.py::TestRun::run-bools.test::testBoolOps
- mypyc/test/test_run.py::TestRun::run-i64.test::testI64BasicOps
- mypyc/test/test_run.py::TestRun::run-i64.test::testI64DefaultArgValues
- mypyc/test/test_run.py::TestRun::run-i64.test::testI64ErrorValuesAndUndefined
- )
- ;;
- esac
-
- # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
- # fail with high COLUMNS values
- local -x COLUMNS=80
-
- # The tests depend on having in-source compiled extensions if you want to
- # test those compiled extensions. Various crucial test dependencies aren't
- # installed. Even pyproject.toml is needed because that's where pytest args
- # are in. Hack them into the build directory and delete them afterwards.
- # See: https://github.com/python/mypy/issues/16143
- local -x MYPY_TEST_PREFIX="${S}"
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- cp -r "${S}"/{conftest.py,pyproject.toml} . || die
-
- local failed=
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest || failed=1
-
- rm conftest.py pyproject.toml || die
-
- [[ ${failed} ]] && die "epytest failed with ${EPYTHON}"
-}