summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-10-10 10:45:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-10-10 10:48:53 -0500
commit2ea4a585fedf130c3faa5b3d9098258fa1069787 (patch)
tree84a8ea4e2f1db47e13129251cb828590e0664306 /dev-python/monotonic/monotonic-1.5.ebuild
parentdev-python/dnspython: adding py37 support (diff)
downloadgentoo-2ea4a585fedf130c3faa5b3d9098258fa1069787.tar.gz
gentoo-2ea4a585fedf130c3faa5b3d9098258fa1069787.tar.bz2
gentoo-2ea4a585fedf130c3faa5b3d9098258fa1069787.zip
dev-python/monotonic: 1.5 bump with py37 support
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-python/monotonic/monotonic-1.5.ebuild')
-rw-r--r--dev-python/monotonic/monotonic-1.5.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/monotonic/monotonic-1.5.ebuild b/dev-python/monotonic/monotonic-1.5.ebuild
new file mode 100644
index 000000000000..72cfe7194bd6
--- /dev/null
+++ b/dev-python/monotonic/monotonic-1.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of time.monotonic() for Python 2 & < 3.3"
+HOMEPAGE="https://github.com/atdt/monotonic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""