summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 22:57:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 23:09:51 +0100
commit1889f313602b0df37b37d16bc25cef56d026b888 (patch)
tree8c49541d38cd88ffbb8b5f41e950031694c90de5 /dev-python/markdown-it-py
parentdev-python/dulwich: Bump to 0.20.32 (diff)
downloadgentoo-1889f313602b0df37b37d16bc25cef56d026b888.tar.gz
gentoo-1889f313602b0df37b37d16bc25cef56d026b888.tar.bz2
gentoo-1889f313602b0df37b37d16bc25cef56d026b888.zip
dev-python/markdown-it-py: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown-it-py')
-rw-r--r--dev-python/markdown-it-py/Manifest1
-rw-r--r--dev-python/markdown-it-py/markdown-it-py-2.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/markdown-it-py/Manifest b/dev-python/markdown-it-py/Manifest
index f6fc23e4fb2c..04ffab946247 100644
--- a/dev-python/markdown-it-py/Manifest
+++ b/dev-python/markdown-it-py/Manifest
@@ -1 +1,2 @@
DIST markdown-it-py-2.0.0.gh.tar.gz 265346 BLAKE2B f509c3fdc82a2665bb9bca862118c544cf203afbb8454cdbb5f58c58aeadcd1fbd66ef98615ac6501e4fe8ce83d2e668de29d2e67301ddda06d1cbbaf6cf7422 SHA512 226111a8d0e57d9def2076053abfba1b7533bb0cdee569b8e1c7ece2b61ebce49daa263aee673683b83974b7597df0e6d62c1723860af684fe306c55619357ca
+DIST markdown-it-py-2.0.1.gh.tar.gz 265850 BLAKE2B fe61608f14b22dffb81bb943df75967300e8366ff1b1c252b35974414efa6b2daac223b09f40ff6d7feab70c5b033b0eee35a4ee5f8523325f12311f4cbeef57 SHA512 fccf00de7e94986a29047da948d6ebb6304ae3645e79bbad480366c3aadbd417b95d96489d167a532eee3c2e17b67e22777224290564c7bcc17d72fec29b08df
diff --git a/dev-python/markdown-it-py/markdown-it-py-2.0.1.ebuild b/dev-python/markdown-it-py/markdown-it-py-2.0.1.ebuild
new file mode 100644
index 000000000000..834cfae053f4
--- /dev/null
+++ b/dev-python/markdown-it-py/markdown-it-py-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python port of markdown-it, Markdown parser"
+HOMEPAGE="https://pypi.org/project/markdown-it-py/
+ https://github.com/executablebooks/markdown-it-py"
+SRC_URI="
+ https://github.com/executablebooks/markdown-it-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/attrs-22[${PYTHON_USEDEP}]
+ dev-python/mdurl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Unimportant tests needing a new dep linkify
+ tests/test_linkify.py::test_token_levels
+ tests/test_port/test_fixtures.py::test_linkify
+)
+
+EPYTEST_IGNORE=(
+ # No need to benchmark
+ benchmarking/
+)