summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-01-08 12:02:51 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-01-08 12:02:51 -0800
commita6f01afa12586460c714705931b92ec6f1d5552f (patch)
tree2c98331c4d3cdeeddfa0f53439f981784a149b96 /dev-python/libtmux/libtmux-0.18.3.ebuild
parentapp-misc/tmuxp: add 1.25.0 (diff)
downloadgentoo-a6f01afa12586460c714705931b92ec6f1d5552f.tar.gz
gentoo-a6f01afa12586460c714705931b92ec6f1d5552f.tar.bz2
gentoo-a6f01afa12586460c714705931b92ec6f1d5552f.zip
dev-python/libtmux: add 0.18.3, drop 0.18.2
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/libtmux/libtmux-0.18.3.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.18.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/libtmux/libtmux-0.18.3.ebuild b/dev-python/libtmux/libtmux-0.18.3.ebuild
new file mode 100644
index 000000000000..62b5e447e740
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.18.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API for tmux"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+)
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ sed -e '/addopts/s:--doctest-docutils-modules::' \
+ -e '/README\.md/d' \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}