summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-python/keyring
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/keyring-13.2.1-r1.ebuild3
-rw-r--r--dev-python/keyring/keyring-13.2.1.ebuild1
-rw-r--r--dev-python/keyring/keyring-15.0.0.ebuild3
-rw-r--r--dev-python/keyring/keyring-18.0.1.ebuild1
4 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/keyring/keyring-13.2.1-r1.ebuild b/dev-python/keyring/keyring-13.2.1-r1.ebuild
index 0cd6bdea71df..a2ddfdf7306f 100644
--- a/dev-python/keyring/keyring-13.2.1-r1.ebuild
+++ b/dev-python/keyring/keyring-13.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,6 +15,7 @@ SLOT="0"
LICENSE="PSF-2"
KEYWORDS="~amd64"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/secretstorage[${PYTHON_USEDEP}]
diff --git a/dev-python/keyring/keyring-13.2.1.ebuild b/dev-python/keyring/keyring-13.2.1.ebuild
index 7601c3a8c00f..3d2fd4e8a798 100644
--- a/dev-python/keyring/keyring-13.2.1.ebuild
+++ b/dev-python/keyring/keyring-13.2.1.ebuild
@@ -15,6 +15,7 @@ SLOT="0"
LICENSE="PSF-2"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/keyring/keyring-15.0.0.ebuild b/dev-python/keyring/keyring-15.0.0.ebuild
index 7a402c3f56ed..9db3a228e23a 100644
--- a/dev-python/keyring/keyring-15.0.0.ebuild
+++ b/dev-python/keyring/keyring-15.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,6 +15,7 @@ SLOT="0"
LICENSE="PSF-2"
KEYWORDS="~amd64"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/secretstorage[${PYTHON_USEDEP}]
diff --git a/dev-python/keyring/keyring-18.0.1.ebuild b/dev-python/keyring/keyring-18.0.1.ebuild
index b66ea9909c0c..28be4645a8a2 100644
--- a/dev-python/keyring/keyring-18.0.1.ebuild
+++ b/dev-python/keyring/keyring-18.0.1.ebuild
@@ -15,6 +15,7 @@ SLOT="0"
LICENSE="PSF-2"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/secretstorage[${PYTHON_USEDEP}]