summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-11 15:09:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-11 15:31:49 +0100
commitfd08bd9cbef67241cb6eb6167b5897b25b75bcc2 (patch)
tree5f375282402053b6fa88e7ac177f1a5e3d4c79ee /dev-python/jupyter_client
parentdev-python/apispec: Bump to 6.0.2 (diff)
downloadgentoo-fd08bd9cbef67241cb6eb6167b5897b25b75bcc2.tar.gz
gentoo-fd08bd9cbef67241cb6eb6167b5897b25b75bcc2.tar.bz2
gentoo-fd08bd9cbef67241cb6eb6167b5897b25b75bcc2.zip
dev-python/jupyter_client: Bump to 7.4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.4.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index c7f76e236cf8..60268e859945 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-7.4.4.tar.gz 327373 BLAKE2B 02f70be181779352706f86515f705addbf68383f16d899a4d30c9d6cb0970e955435a8c934f611f93c9fe2eeb5c0fe3b124f31571ae396995564fb450bf03201 SHA512 6de3b271be03ff90d906fc176ce107799abbf8ac882d32d26d86ab91fd3f8a6fa09e5df4f3955e00bc939a31472d423a0d74396f8ba473440c4bc17cc1a28c2f
+DIST jupyter_client-7.4.5.tar.gz 327597 BLAKE2B f159d347cf8391c9d3c29327a6c93831e35e7540fb6a0ffe3f59539a7cf5822c562fbb3388ad398a5a6bf87bdd1bc5c6713b9424300d2adb28d93f2a4dafd9c4 SHA512 bef4603222504e40d2ecaf781ea461ba6be8ee32c217e2bf5ec25b83349cec32b3a62e30019ddc75f000bac3fd69ecd6895322f8dcbf953a776dab292b6cca1b
diff --git a/dev-python/jupyter_client/jupyter_client-7.4.5.ebuild b/dev-python/jupyter_client/jupyter_client-7.4.5.ebuild
new file mode 100644
index 000000000000..36545e34222b
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.4.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.12[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest