summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-14 15:19:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-14 15:19:22 +0200
commit9492595553aa0ab558c84c8aa4f002e931274e38 (patch)
tree8e90857b80a638f09da4acba100c3cdcf7c318ef /dev-python/jupyter-client
parentdev-python/jupyter_client: Remove old (diff)
downloadgentoo-9492595553aa0ab558c84c8aa4f002e931274e38.tar.gz
gentoo-9492595553aa0ab558c84c8aa4f002e931274e38.tar.bz2
gentoo-9492595553aa0ab558c84c8aa4f002e931274e38.zip
Rename dev-python/{jupyter_client → jupyter-client}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest3
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.0.3.ebuild49
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.1.0.ebuild49
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.2.0.ebuild49
-rw-r--r--dev-python/jupyter-client/metadata.xml23
5 files changed, 173 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
new file mode 100644
index 000000000000..ba4e36dadfe1
--- /dev/null
+++ b/dev-python/jupyter-client/Manifest
@@ -0,0 +1,3 @@
+DIST jupyter_client-8.0.3.tar.gz 334366 BLAKE2B 04ea6e8206fe0b741da1ba0d17cb559657824c20f4fcff48fd0ce4287dce7da9a151000e7a0f08cbf3fa6b1868d8d7e424d49d70a258283466350946f4ce5220 SHA512 27eca49e44c13d819624c6ab596b24b9b469f82a788920eb4db02cee43c2efdf22ea68bf282f5f4ca28d38c9238d51d70d7aa214f2c3b8f6c2a7ebcaf12d567c
+DIST jupyter_client-8.1.0.tar.gz 335241 BLAKE2B d9491f958b21ba09494bf42ff5a3bae786388a16c007f5756df8900fc53c6fdb4d67bff09b16290338d07fc3c3466483f20ab82482fb235e0e55481294eaeef1 SHA512 21317e5ca61b72408e94116f0be545753088d891742579fcf7a451be179a7783dc153d2898e0ff50ce06017f90cb48f907a5bb056090b13ec0da2af7287f6dcd
+DIST jupyter_client-8.2.0.tar.gz 335567 BLAKE2B e02f8813d12ec8ba0e15291dad04cfaeeb98ea524050a10d142d74af203e43aa1c2e22e7fd7b071c05831b3dd644985a42e38f59fee65f4570e5eb88bbc9fbb1 SHA512 1337c4f2d93d9cd2ae5e3d8f30a8e4af69dad6e09c97e949d9300df0668be4da91134c73da06eb417c10ff2c09fd7beb28699e7a17502ceee3453cb9323b4363
diff --git a/dev-python/jupyter-client/jupyter-client-8.0.3.ebuild b/dev-python/jupyter-client/jupyter-client-8.0.3.ebuild
new file mode 100644
index 000000000000..5b8619ab0d01
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)
diff --git a/dev-python/jupyter-client/jupyter-client-8.1.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.1.0.ebuild
new file mode 100644
index 000000000000..503ce6564a01
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)
diff --git a/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild
new file mode 100644
index 000000000000..f94d688c0313
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)
diff --git a/dev-python/jupyter-client/metadata.xml b/dev-python/jupyter-client/metadata.xml
new file mode 100644
index 000000000000..a41692a7eeae
--- /dev/null
+++ b/dev-python/jupyter-client/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ Contains the reference implementation of the Jupyter protocol. It
+ also provides client and kernel management APIs for working with
+ kernels. It also provides the jupyter kernelspec entrypoint for
+ installing kernelspecs for use with Jupyter frontends.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jupyter/jupyter_client</remote-id>
+ <remote-id type="pypi">jupyter-client</remote-id>
+ </upstream>
+</pkgmetadata>