summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-02 08:33:37 +0000
committerSam James <sam@gentoo.org>2021-03-02 08:40:23 +0000
commit1d3bf8c16f87ab43e1fea3eecd0103491930da5c (patch)
tree0d84a433cbdf028c0bd6c546d07b16267122defb /dev-python/jellyfish
parentdev-python/ipaddr: mark ALLARCHES (diff)
downloadgentoo-1d3bf8c16f87ab43e1fea3eecd0103491930da5c.tar.gz
gentoo-1d3bf8c16f87ab43e1fea3eecd0103491930da5c.tar.bz2
gentoo-1d3bf8c16f87ab43e1fea3eecd0103491930da5c.zip
dev-python/jellyfish: Python 3.9, modernise
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/jellyfish')
-rw-r--r--dev-python/jellyfish/jellyfish-0.8.2.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/dev-python/jellyfish/jellyfish-0.8.2.ebuild b/dev-python/jellyfish/jellyfish-0.8.2.ebuild
index d53e8eaf9cf3..992a3ad23ed9 100644
--- a/dev-python/jellyfish/jellyfish-0.8.2.ebuild
+++ b/dev-python/jellyfish/jellyfish-0.8.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
@@ -13,24 +13,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/unicodecsv[${PYTHON_USEDEP}]
)
"
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( build/sphinx/html/. )
- fi
-}
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
python_test() {
cp -r testdata "${BUILD_DIR}" || die