summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-22 07:04:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-22 07:04:49 +0200
commit3195a9adbaa049440a6f4401d484e8f5cab0e3e7 (patch)
tree4c1166919b0c29a5df93fde82c51b027996768b7 /dev-python/jaraco-stream
parentdev-python/werkzeug: Bump to 3.0.4 (diff)
downloadgentoo-3195a9adbaa049440a6f4401d484e8f5cab0e3e7.tar.gz
gentoo-3195a9adbaa049440a6f4401d484e8f5cab0e3e7.tar.bz2
gentoo-3195a9adbaa049440a6f4401d484e8f5cab0e3e7.zip
dev-python/jaraco-stream: Bump to 3.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-stream')
-rw-r--r--dev-python/jaraco-stream/Manifest1
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
index 162ce0772cd6..7596cdf9a20f 100644
--- a/dev-python/jaraco-stream/Manifest
+++ b/dev-python/jaraco-stream/Manifest
@@ -1 +1,2 @@
DIST jaraco.stream-3.0.3.tar.gz 8877 BLAKE2B 85289efe8e04e93cbceb0053f5025cad3d073deeb113806e25ca06fb88a9b082de6805305de85d1f17b77f61d2d0f4683b2b21f670102b03112b8f7a3fdafd91 SHA512 fe50c21b26e734c9c2d0b7cf8a1c8cc8bab80417adf073a4ae213ba4067aa33e2f6c8886aac996971d2f98aacd295d9999aa3ac7dba24dd952cc27d15bef22e2
+DIST jaraco_stream-3.0.4.tar.gz 10744 BLAKE2B dab536ba2927c361deb86500d2ac294351c18098f2f69b6f40f54a68ae438dad094ee5075ab6d1c73a7ccd6a05bf98edbbc5cf2441ecd68cef0c4129e94aa47f SHA512 f17647fd2dd1fcdc04d6ef62a95fe63d3f1c7e3acbc72600a414930c4b5d781b4148aff4bda94a47f6ece5c9666b976b321647e3f07c37ffb1ee2003bb075b07
diff --git a/dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild b/dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild
new file mode 100644
index 000000000000..f54c303f5af4
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.stream/
+ https://pypi.org/project/jaraco.stream/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest