summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-05 06:55:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-05 06:58:12 +0200
commitfd3e64ca309aea67d8cf907779f7cca42be28672 (patch)
treedb43123c74e7c8bfc094ed2bde4569fd4d621ef9 /dev-python/ipywidgets
parentdev-python/widgetsnbextension: Bump to 4.0.11 (diff)
downloadgentoo-fd3e64ca309aea67d8cf907779f7cca42be28672.tar.gz
gentoo-fd3e64ca309aea67d8cf907779f7cca42be28672.tar.bz2
gentoo-fd3e64ca309aea67d8cf907779f7cca42be28672.zip
dev-python/ipywidgets: Bump to 8.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.1.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 1443735e1c3b..1fda580bd53c 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1 +1,2 @@
DIST ipywidgets-8.1.2.tar.gz 116492 BLAKE2B 0fc8283b332447cd3659d39d4564e2e794678169c7bc156660f3478251c4df23de1719e4fcf9651b9766506edf359bdfc803b1450520a3cbce290b39bd95bd3c SHA512 59ddc92bb9b18b6cd36b1499465e700ce9b11010e2d51cdf0a820b36efecbea1facab42ced2f61de312319f4fd4e672bb27b248d40ee0088f3b58acfd102ab61
+DIST ipywidgets-8.1.3.tar.gz 116515 BLAKE2B b7a11e7078ddbd99b8713fc3aa63c78118bf00b64c376412c608a622fda1e7d0430accb0959a56a474d2eeba4b5ce531255b52bba591f2806833644e47f2a7bd SHA512 3722e3716f367c6dce88c6ec401d23240c214793672ae76a12b672f77c7c801775d3253e1202749e54832d9dc13e4bb5984ec57e21607f12c22aced8874538db
diff --git a/dev-python/ipywidgets/ipywidgets-8.1.3.ebuild b/dev-python/ipywidgets/ipywidgets-8.1.3.ebuild
new file mode 100644
index 000000000000..d2c831f90006
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.1.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/comm-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-4.0.11[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab_widgets-3.0.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ <dev-python/pytest-8.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/ipython-6.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/4892
+ ipywidgets/widgets/tests/test_interaction.py::test_interact_noinspect
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}