summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-15 03:29:01 +0000
committerSam James <sam@gentoo.org>2021-11-15 03:29:01 +0000
commit125ae59fa6abc9f0df8473127e4ea02460602818 (patch)
tree152bd655668b544eb3a9d817ed0c6df440fb265c /dev-python/ipykernel/ipykernel-6.5.0.ebuild
parentdev-python/ipykernel: add 6.5.0 (diff)
downloadgentoo-125ae59fa6abc9f0df8473127e4ea02460602818.tar.gz
gentoo-125ae59fa6abc9f0df8473127e4ea02460602818.tar.bz2
gentoo-125ae59fa6abc9f0df8473127e4ea02460602818.zip
dev-python/ipykernel: Revert "add 6.5.0"
This reverts commit 2e5596bd7b452e3223c81f3cc05665aa238577ee. Forgot to give credit in the commit message, let's try again... Bug: https://bugs.gentoo.org/822477 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/ipykernel/ipykernel-6.5.0.ebuild')
-rw-r--r--dev-python/ipykernel/ipykernel-6.5.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/ipykernel/ipykernel-6.5.0.ebuild b/dev-python/ipykernel/ipykernel-6.5.0.ebuild
deleted file mode 100644
index 4d505eef8ded..000000000000
--- a/dev-python/ipykernel/ipykernel-6.5.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-DESCRIPTION="IPython Kernel for Jupyter"
-HOMEPAGE="https://github.com/ipython/ipykernel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- <dev-python/importlib_metadata-5.0.0[${PYTHON_USEDEP}]
- >=dev-python/argcomplete-1.12.3[${PYTHON_USEDEP}]
- ' python3_8 pypy3)
- >=dev-python/debugpy-1.0.0[${PYTHON_USEDEP}]
- <dev-python/debugpy-2.0[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
- <dev-python/ipython-8.0[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1.0[${PYTHON_USEDEP}]
- <dev-python/traitlets-6.0[${PYTHON_USEDEP}]
- <dev-python/jupyter_client-8.0[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2[${PYTHON_USEDEP}]
- <www-servers/tornado-7.0[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-inline-0.1.0[${PYTHON_USEDEP}]
- <dev-python/matplotlib-inline-0.2.0[${PYTHON_USEDEP}]
-"
-# RDEPEND seems specifically needed in BDEPEND, at least jupyter
-# bug #816486
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
- dev-python/ipyparallel[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.5.0-drop-pytest-cov.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
- distutils-r1_src_prepare
-}