summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-17 10:20:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-17 10:55:40 +0100
commitb9a6148727d60b26b58288d209c113757777fa35 (patch)
treeff6fc9828f6f47bf75e6ba9036128ac35b15be30 /dev-python/hypothesis
parentdev-python/django-taggit: Bump to 2.0.0 (diff)
downloadgentoo-b9a6148727d60b26b58288d209c113757777fa35.tar.gz
gentoo-b9a6148727d60b26b58288d209c113757777fa35.tar.bz2
gentoo-b9a6148727d60b26b58288d209c113757777fa35.zip
dev-python/hypothesis: Bump to 6.24.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.24.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index f1e5b9bfc749..3d610cec26b7 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,2 +1,3 @@
DIST hypothesis-python-6.24.2.tar.gz 9168397 BLAKE2B 87070841a01c7c9de79b5d786867024873f7de186bbee01bba708e783fd1268523b2e0398a055c92b782f27d0f67679bf5852bd49371932d277726517d12bd91 SHA512 9e4ee194fe561f8a39a26ab63cad4b6f093b2fcb56d02a5adfc4bdee1d7ccf55e6712d1af41d17155c6e88ecc75e6f191cf2761c2d71c2c052d7e8259cff0326
DIST hypothesis-python-6.24.4.tar.gz 9168664 BLAKE2B fe3d2fa28d7e8f47e4ce60fa91b3e004e3214ff51372b16f56c8328ef08a0dace48545b198511ceefe9f58b907f3b35d65ad2934c936dc1ef0b6393215e8c2d9 SHA512 4c1ea50b3203c2933713a5ebfdf40b64c0f6ab62bad30de446e26c79a8e5212b0669ca2569be9f5367b42471175225952920a68129867b4c94fe76b214b88a47
+DIST hypothesis-python-6.24.5.tar.gz 9168940 BLAKE2B 719efd5c307708f3fa205e2096e54ad44009248bd6c03873cbf14eaacb48c5aaf2f444b430418ae3d6d107b53def52a0a6194d9827e94abb1c97af4f12f02072 SHA512 215c4009b9496983c1c3bb3fee7c051fed434c57d48dbcaa5ff0aa42c60c33a507c424eb7e604d323b61c6171d97cbd02d492bcda99bc278b099fd2f3fb074ca
diff --git a/dev-python/hypothesis/hypothesis-6.24.5.ebuild b/dev-python/hypothesis/hypothesis-6.24.5.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.24.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}