summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-17 04:26:35 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-17 04:26:35 +0100
commita3ac65e82922ba8b837be3221f11cd0a5c9bdd37 (patch)
tree6073678fd7fb7f5f7b21938f1e6afb11f4eaecb9 /dev-python/hypothesis
parentdev-python/zeroconf: Bump to 0.140.1 (diff)
downloadgentoo-a3ac65e82922ba8b837be3221f11cd0a5c9bdd37.tar.gz
gentoo-a3ac65e82922ba8b837be3221f11cd0a5c9bdd37.tar.bz2
gentoo-a3ac65e82922ba8b837be3221f11cd0a5c9bdd37.zip
dev-python/hypothesis: Bump to 6.124.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.124.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 08fd177f658e..d0c6584e8956 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-6.123.16.gh.tar.gz 9507597 BLAKE2B 15876ea1a5a8c7916ea8724a84889
DIST hypothesis-6.123.17.gh.tar.gz 9508250 BLAKE2B 494c41299a646856050889e2093dae477386c76ac3e57576698178a65cfe4b3bb7a2cfe19204904ae0ca8d25cf8d347389c7eb76b7d8ac046067fc4b11bd509f SHA512 73f2c2cd1bb9063d74448cfba0f85308398b52fcb0cd948a64b6396f698b914154a93b7afdf2b3c32a902f21f6a84996218572af700c35c518d9a41bbe6cae8f
DIST hypothesis-6.123.2.gh.tar.gz 9506171 BLAKE2B a7033cf2b5d56753ce19c5b369889b62d88c86df8254c840341c599dd97f575fc84e73236e701f4303d6141146bdef24f13f8d666f30a578ff80b067976934ba SHA512 d46b3d83a14b629a39f7eb2dcb0915802ee8185b4796ea38d053e44f2e8e4025a053c99a0aea7b4b59442a24fd3600b78d5a19e1f0bbd13e8a2d9f93cdca3df6
DIST hypothesis-6.123.7.gh.tar.gz 9509012 BLAKE2B 71def0634aee97b4d64bacf9b4a09e091fb209c9de2d2ecbcbb86ad0f7bc2e330e7d7b93e1c810b864fd80ecd82eb6bf51aaf6a6de99c74c338609062ce1e90e SHA512 00b26f4e040a948aaf64554ee395fad4c9b0bb116c87d97bd3ef20be1d25068a79ed1c856c497c1d3d5122481386625c3323be77c0ec851fab823a706350b437
+DIST hypothesis-6.124.0.gh.tar.gz 9509075 BLAKE2B 06bcce0c2f3772ae16c623367e53410b1d5237a2f62f77643080d69e4b32b47f0cbbeba98c66a83247c35d3d6a3d9e7c6493383393a13fc63d86792ef464ca59 SHA512 f876e18fcc784f9b61c18435c66a9aaf9aee76875f5d5e29dbca31448421e7691977660946ea5e3d3f0c33d740ddee55d860995636ff54706cd5c01d39663dc4
diff --git a/dev-python/hypothesis/hypothesis-6.124.0.ebuild b/dev-python/hypothesis/hypothesis-6.124.0.ebuild
new file mode 100644
index 000000000000..4486f30faf3d
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.124.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -p rerunfailures --reruns=5 \
+ tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}