summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-17 10:06:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-17 10:21:38 +0100
commit89b12cf4bc3cfdba965d476780678080192c43b9 (patch)
treeac9f037ed871bedb9bf171b3e7b432df225a3c67 /dev-python/hypothesis
parentdev-java/slf4j-nop: bump to 1.7.32 (diff)
downloadgentoo-89b12cf4bc3cfdba965d476780678080192c43b9.tar.gz
gentoo-89b12cf4bc3cfdba965d476780678080192c43b9.tar.bz2
gentoo-89b12cf4bc3cfdba965d476780678080192c43b9.zip
dev-python/hypothesis: Bump to 6.35.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.35.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index ecb290f25188..f5b8f7c043db 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-6.33.0.tar.gz 9177426 BLAKE2B ad1b1a358345f9b92bf41cee196
DIST hypothesis-python-6.34.1.tar.gz 9178792 BLAKE2B 72cbb1b372fb23da8ecf4eb8355cb054216c78b6464b5ddbc7ee5534652d69e4f3cc094241c0434bc0d80cc555c87699504f87bcf4659724f77d70deaa19b871 SHA512 234b8a814994b0e93cae24233cc30ab8eba853a081d4cce4309b4af5e13234a3de8d704f3255cce11195603645c2641fa1985529d64631df90a61cfd1c4a7f06
DIST hypothesis-python-6.34.2.tar.gz 9178843 BLAKE2B 24bbc19ea5c207880d577a3c451f6e90c4b124a934aa1cd103c11ec77cbb5076d75e3860abd2b9bd2fc75640ba562b81d3fa038cc7752109625990e0ac0e1039 SHA512 a03233a2b84b1e009ad246663b0c7f6b56f2c04d08d69297ff50b02b8af292fdee37f877ca2f709e6ef64192d31e3d9bf18f78a6f5c92b8f03bf04ba398d063c
DIST hypothesis-python-6.35.0.tar.gz 9178905 BLAKE2B 7cb55da84b979d8a075361674bbfa00cfeb5276e0ae25c153794fd876d1f65c7a88c5cc16e8b0c085560be937be14a113ba4854b734808b592f3d7c0be30215f SHA512 b390272ac471b23d8de1414cb7e2fd9d814318bc1063e4ad2bb2d61ba3b3af0c92701fa7a737117dc894a71e8d0473f52c11caf70fbb35d0837a4927537daaf5
+DIST hypothesis-python-6.35.1.tar.gz 9179056 BLAKE2B 3667ed7fe2a5402a3055941c44afe8e3e909381a0cbc1bec61cdcec18cb102796d283c737d5642ff6242fee4f0a2dc88774befe880a58f64bb4e183789b21e09 SHA512 839c9b2cf607f44fccf20c814a774889484f61a40a93e976f7bcb457dceac272bf6b775231fb36009e115181cf2089907bcad898f795e266d98ca218c5c4af28
diff --git a/dev-python/hypothesis/hypothesis-6.35.1.ebuild b/dev-python/hypothesis/hypothesis-6.35.1.ebuild
new file mode 100644
index 000000000000..3c5d5893f458
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.35.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{8..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}