summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-28 06:18:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-28 07:43:31 +0100
commit3e4b9181e89c964948551adcf4cc6896d7d1a808 (patch)
treef6a5413cf748ea001fad203012a748ba33ce67d6 /dev-python/hypothesis
parentdev-python/hypothesis: Remove old (diff)
downloadgentoo-3e4b9181e89c964948551adcf4cc6896d7d1a808.tar.gz
gentoo-3e4b9181e89c964948551adcf4cc6896d7d1a808.tar.bz2
gentoo-3e4b9181e89c964948551adcf4cc6896d7d1a808.zip
dev-python/hypothesis: Bump to 6.120.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.120.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index d264f92ae431..9160ad10012d 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-6.116.0.gh.tar.gz 9480480 BLAKE2B 350abfd8bad65a33669345a71c3df9737e4defcfc12cd81a1d9ecb5603310372e039d1a148c2223a71f37f0ad485ca892ba322f9404e6d873016193b7f864f88 SHA512 5ae6848f16c21b9012d15eb71715df1fc9448b70264d18453d13e61fd71b84623150ce32c9b50ea4ce95494b0df21907368d0f6fabaa8cb8b26c71e474885703
DIST hypothesis-6.118.9.gh.tar.gz 9487943 BLAKE2B 3c8d17d2763877107c7342d9a9825cb733de91ce6c99c88ed7536ac0e82d728f54d762c9b26cb02d742c470afc05c2798fb20e1f3c6f52d3b9d0e2c9cea9e99a SHA512 ba4f32892088a3a4d1a3d9ca2d28b9828cd7e2f4c4878733943f34f431014d4ba4dfe07729878b4c87cc295b6d6f219094c1f774ac115acd3b375ecc3c58d580
DIST hypothesis-6.119.4.gh.tar.gz 9490666 BLAKE2B 99a45054b90026317bca165915b2ffe3b3abfa03a98efc6181bd64f6ca851f9a90e4ba1b41ba4f3b2181de02818a91367f1c29523b78bca303da4eea31db1284 SHA512 003b01fd3e1e4ae2ea68f72b80063928dd56a069fdf8b6ffc73f6ffb3db4b048523564bd616d604d04a3ea55b19c01940ad7ba60bf1e88c54e29359ca0e397db
+DIST hypothesis-6.120.0.gh.tar.gz 9491124 BLAKE2B 56e2441f7f1daddfac37d4288513d6140c9af01764bd32e5a14b1ae91982c28038c077038cbe278a48db77029af188857561122c6b347b6ea1992f46ab77f2d0 SHA512 9bf39b114cc9fa4eda77651bc02433c49f1d6526827a65086ca911839e4d8a7bf245b4e47b07f71ae533904c3ba90498bc632a6e18d3b8ef8e632a5d1a31b0ec
diff --git a/dev-python/hypothesis/hypothesis-6.120.0.ebuild b/dev-python/hypothesis/hypothesis-6.120.0.ebuild
new file mode 100644
index 000000000000..dde5562c67da
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.120.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -p rerunfailures --reruns=5 \
+ tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}