summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-07 17:42:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-07 17:42:53 +0100
commit71eeb2eb46529f562391d0464d73a5e5275c9b16 (patch)
treeafb7aa5181bda8dd787e032d1aff53459ffda255 /dev-python/huawei-lte-api
parentdev-python/xmlschema: Bump to 3.0.0 (diff)
downloadgentoo-71eeb2eb46529f562391d0464d73a5e5275c9b16.tar.gz
gentoo-71eeb2eb46529f562391d0464d73a5e5275c9b16.tar.bz2
gentoo-71eeb2eb46529f562391d0464d73a5e5275c9b16.zip
dev-python/huawei-lte-api: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/huawei-lte-api')
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.8.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
index 806f4f4a07a9..85069c3d0228 100644
--- a/dev-python/huawei-lte-api/Manifest
+++ b/dev-python/huawei-lte-api/Manifest
@@ -1 +1,2 @@
DIST huawei-lte-api-1.7.3.gh.tar.gz 39166 BLAKE2B 52e2ab89a2ab6aadccd92192c73f1ef5ac4aa376dc6b5e29f9460881ccd3e600744789d33d490efa86315b5ad9f6090d56a45132ae3dc421dc5025032319ed59 SHA512 83bdfae0b8d44789ebfe8f94233b4d5b49fe3e379f25205fe71970d533ecbd0611c13cfbe3471c9331b4bcde6c737aaf53156c397d7016e5de5cc053f221374b
+DIST huawei-lte-api-1.8.1.gh.tar.gz 40698 BLAKE2B 61e2e6399b106e7efe68ed50d0d3e17ca4b243d62c2b4d00215141931f806ef09c7bee826e50b2b37f7bc8cdb663912019470932a1aa491e0ca582f4ea7baa8d SHA512 704c9f18db74aaa544888c761a934e9886460ce5e1848e1e221ed05cedf1357a0bcce758d2afe126dfd39739d7819520a5fc82a19315647f38f058fbe60d0511
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.8.1.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.8.1.ebuild
new file mode 100644
index 000000000000..8793f24f8b46
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="
+ https://github.com/Salamek/huawei-lte-api/
+ https://pypi.org/project/huawei-lte-api/
+"
+SRC_URI="
+ https://github.com/Salamek/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # make cryptodome-friendly
+ sed -i -e 's:pycryptodomex:pycryptodome:' setup.py || die
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:g' {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest