summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-13 08:54:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-13 10:55:54 +0200
commit2381dce4ac1ad23cc9d316852be54ce92b56dd88 (patch)
treea57130f5bdbf3b2578bcbd35457e7d112dc60df5 /dev-python/httpretty
parentdev-db/phpmyadmin: bump to 5.1.0 (diff)
downloadgentoo-2381dce4ac1ad23cc9d316852be54ce92b56dd88.tar.gz
gentoo-2381dce4ac1ad23cc9d316852be54ce92b56dd88.tar.bz2
gentoo-2381dce4ac1ad23cc9d316852be54ce92b56dd88.zip
dev-python/httpretty: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/Manifest1
-rw-r--r--dev-python/httpretty/httpretty-1.1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index f17cb3a0077a..db7310469b9f 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1 +1,2 @@
DIST httpretty-1.0.5.tar.gz 414946 BLAKE2B 8bbaac3d53fbf5744f7bf8ef952bd9305112934af24809a233ef0446886e09b7d2a897e69aded12d9e715580305d729609365b0be55f8d324cc48e6aa0699d75 SHA512 2e5f4834848ab1a0b84230f000afb0409b30b3cc1769d36ad61f712f56abc8d6076e7507598f791fe343ce282cf9e26939add71ef794ead2836badfc2321d6bb
+DIST httpretty-1.1.0.tar.gz 417966 BLAKE2B 2decbfdb8b8a1e04bc2a985bb605d59ef2ee84a434dcd3c420ecf68857a5a409cee622db63bb5bf8981c1bf287b7dcf56cf91360fec4dd219dc349b1d4425a6d SHA512 a6da71115d4dc12125bec451888c30858ec94f2a3aec530b21efcacd9c595cb3d2196dbca3631f4b6f50c985c14b3c4bc6f34ec1d9e41aaf2b48fc8a072f5739
diff --git a/dev-python/httpretty/httpretty-1.1.0.ebuild b/dev-python/httpretty/httpretty-1.1.0.ebuild
new file mode 100644
index 000000000000..4945fbd3c3e3
--- /dev/null
+++ b/dev-python/httpretty/httpretty-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+# redis skipped as it requires a redis server running
+DEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # remove useless deps
+ sed -i -e '/rednose/d' setup.cfg || die
+ # tests requiring network access
+ rm tests/functional/test_passthrough.py || die
+ # requires running redis server
+ # it is skipped correctly but it causes unnecessary dep on redis-py
+ rm tests/functional/bugfixes/test_redis.py || die
+
+ distutils-r1_python_prepare_all
+}