summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 01:58:24 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 02:02:03 -0400
commit327c6e76c9d3bc42f23f233d45c002dae31b4fa2 (patch)
tree803c1e45bb41d2aae0c4d518725ffc1d28053522 /dev-python/html5lib
parentapp-vim/vim-latex: remove old (diff)
downloadgentoo-327c6e76c9d3bc42f23f233d45c002dae31b4fa2.tar.gz
gentoo-327c6e76c9d3bc42f23f233d45c002dae31b4fa2.tar.bz2
gentoo-327c6e76c9d3bc42f23f233d45c002dae31b4fa2.zip
dev-python/html5lib: version bump to 1.0.1
Closes: https://bugs.gentoo.org/648186
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/Manifest1
-rw-r--r--dev-python/html5lib/html5lib-1.0.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
index 5cb6a678178e..78528b7f6814 100644
--- a/dev-python/html5lib/Manifest
+++ b/dev-python/html5lib/Manifest
@@ -1,2 +1,3 @@
DIST html5lib-0.9999999.tar.gz 889312 BLAKE2B 49cbab503692a1044ef37b11d9b776fb0378c19f1cbe05b259b4653d248e3571e5578d7879ab3ec5df2e750db74c353acc98d1d6e8556949c1b1efb62f38c116 SHA512 1748a1921f4bc93b7f208d89701eeabfe507e40515dd2e88ece239ba7c1704c8ae9dc4eea310164c7b207225dce910f78a8b34f826f4f87a2992365c07089c28
DIST html5lib-0.999999999.tar.gz 245488 BLAKE2B 3d2409f18e7ff6b6882e163b782703a7d2b2d42f8c131ab05a51499a4cd23d75ff8d097c1ce87e9f28e8ce649bec8099d364f4d01ee64d0efdfc75fba1d01067 SHA512 b30d9ea74d0ad03e07ebee0d33caefeed717e6084f2ef44559ebf73948563ffd60e40c774e23c8964a32b0f265d1d1f0b98759861acaa208f28e5ab2813c3ca0
+DIST html5lib-1.0.1.tar.gz 252959 BLAKE2B d2a9fa19d6a18b9e0c39f737a22ff4d5a6533734843f787c083f9497fd94788dad0e1e96478fe48b262c208370cf58e91ab94cc06a3e2757a40e936363cd3148 SHA512 35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2
diff --git a/dev-python/html5lib/html5lib-1.0.1.ebuild b/dev-python/html5lib/html5lib-1.0.1.ebuild
new file mode 100644
index 000000000000..1e9cddcf638b
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}