summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-01 15:32:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-01 15:41:24 +0100
commitacee12193d14601aa45454a4da1b7e6d833e7e2e (patch)
tree78f0366d21375197a0d29b5e3835c3e2830ab420 /dev-python/hatch-fancy-pypi-readme
parentdev-python/hypercorn: Bump to 0.16.0 (diff)
downloadgentoo-acee12193d14601aa45454a4da1b7e6d833e7e2e.tar.gz
gentoo-acee12193d14601aa45454a4da1b7e6d833e7e2e.tar.bz2
gentoo-acee12193d14601aa45454a4da1b7e6d833e7e2e.zip
dev-python/hatch-fancy-pypi-readme: Bump to 24.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatch-fancy-pypi-readme')
-rw-r--r--dev-python/hatch-fancy-pypi-readme/Manifest1
-rw-r--r--dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-24.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/hatch-fancy-pypi-readme/Manifest b/dev-python/hatch-fancy-pypi-readme/Manifest
index c161453dd7cb..12e2b663042f 100644
--- a/dev-python/hatch-fancy-pypi-readme/Manifest
+++ b/dev-python/hatch-fancy-pypi-readme/Manifest
@@ -1,2 +1,3 @@
DIST hatch-fancy-pypi-readme-23.1.0.gh.tar.gz 27878 BLAKE2B 934e7e1b8000feb554014dd3594724943173f1b5d78d1072e5612dde744d3cea925e49e46e0eddff7408211439c9f9efc24c488e6ce73fe9955bb5bf5d851b6d SHA512 a26b8205877815292c7c65380f3fff43a3222ec5044556a29fb0b570f0822b548f8f4403cb6a800044671692806b257ecee5f9ec0f3efb597e9a5780a8885424
DIST hatch-fancy-pypi-readme-23.2.0.gh.tar.gz 28280 BLAKE2B d868f18fc8593626792225025305a0cc3fa915cdcb041371fad1b50a8fb590f184371586265b0c038229b8332494c1cdb5818065493762920667166af084ecc7 SHA512 eb678326fc6bc440c1bd64513ca235c628eaac73c16d9272c160acc8aa116076d8ac5bcdec7176c1299d5598c3025a2dce78a17a07c456ff2973245cdf722a7e
+DIST hatch-fancy-pypi-readme-24.1.0.gh.tar.gz 28370 BLAKE2B 5f0783e63d23f102dd43ddb8b0906ca5d971e2ab0db4055eef62fcf84476790910db006359c20277be902985b7d4ab8e90e1389456d514930cef67ccfee70cec SHA512 fc659ae9a3646e4d013827d82cc75545d2b6b7ea0fa72491b51acf63f264fd764ec0bf99e894244be6fe402eaf0fc458bc95f565822387dda528dbd0347e1202
diff --git a/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-24.1.0.ebuild b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-24.1.0.ebuild
new file mode 100644
index 000000000000..48f8bacd53b1
--- /dev/null
+++ b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-24.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fancy PyPI READMEs with Hatch"
+HOMEPAGE="
+ https://pypi.org/project/hatch-fancy-pypi-readme/
+ https://github.com/hynek/hatch-fancy-pypi-readme/
+"
+SRC_URI="
+ https://github.com/hynek/hatch-fancy-pypi-readme/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/hatchling[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails without Internet (via pip)
+ tests/test_end_to_end.py
+)