summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2022-11-20 18:31:41 +0000
committerMart Raudsepp <leio@gentoo.org>2022-11-20 18:33:44 +0000
commitb83fa943e8b8b4f1d09bf795991f4eae4a6f673b (patch)
tree6ea0d22cc5956976d4a1e86052a2b627d82a9141 /dev-python/gst-python
parentmedia-libs/gstreamer: drop 1.20.2 (diff)
downloadgentoo-b83fa943e8b8b4f1d09bf795991f4eae4a6f673b.tar.gz
gentoo-b83fa943e8b8b4f1d09bf795991f4eae4a6f673b.tar.bz2
gentoo-b83fa943e8b8b4f1d09bf795991f4eae4a6f673b.zip
dev-python/gst-python: drop 1.20.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.20.2.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 9548e1ddf9da..381060a8d82c 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,3 +1,2 @@
-DIST gst-python-1.20.2.tar.xz 153428 BLAKE2B 051be5996530989b0e016662f4bf33ac01d576dff56ef779ae481f6f02143595cb3132b9a1ad56cd26f7de55c5df28d25cac448ef28f1b8595974f468252c6b5 SHA512 99af8bad76f930e6c11dcacac013ffe30670ad77259ebe96ee6059a9c359fd1a9c9b22188856f2f19f31469c152b3ad269ba821d06ef92f0c92b3b0fe0eac0d2
DIST gst-python-1.20.3.tar.xz 155504 BLAKE2B 2991f106a53da6e968bdbf2b081c464e92902e4b5ed57e7a14ef1c1556ba18d2e63f4402e703953513f68c36405478b0da05f283602f564bec16cbe72b9e686f SHA512 987b444d78b5fb206457245b46b843db9372f9bd316abc57ecd8d50488ef734707a08ac88a9b9d58e2db113e67ce5b524aad82c0086471494c2177c2e272de6e
DIST gst-python-1.20.4.tar.xz 158816 BLAKE2B cf163882a63db3ef4b9bf5910653a2f0fe5a911f4002b5706aeeef1dae14b6a5bcd0dca17889424c91874bd7e787c137b4d1bbe30471593b0bd01cb116ade294 SHA512 1eaf02dd2733c31eec45d999a23c3e35ff7ab71ef88524cb0aac666a7d2972fa7cd49528d7f3e32364c6a3d7386e14b6b4e43c6d607b751938a0345f3c540260
diff --git a/dev-python/gst-python/gst-python-1.20.2.ebuild b/dev-python/gst-python/gst-python-1.20.2.ebuild
deleted file mode 100644
index 911b008ead42..000000000000
--- a/dev-python/gst-python/gst-python-1.20.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit meson python-r1 xdg-utils
-
-DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="1.0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=media-libs/gstreamer-${PV}:1.0[introspection]
- >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
- >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
-
- # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
- # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
- # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
- sed -e '/subdir.*plugin/d' -i meson.build || die
- sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
-
- xdg_environment_reset
-}
-
-src_configure() {
- configuring() {
- meson_src_configure \
- -Dpython="${EPYTHON}"
- }
- python_foreach_impl configuring
-}
-
-src_compile() {
- python_foreach_impl meson_src_compile
-}
-
-src_test() {
- python_foreach_impl meson_src_test
-}
-
-src_install() {
- installing() {
- meson_src_install
- python_optimize
- }
- python_foreach_impl installing
-}