summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-20 07:14:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-20 07:38:24 +0200
commitf73b86cad9465f58a83cca2a064e18663b0d1372 (patch)
tree61c5d6cfe92c4972c482b9c88dc03c3b6814f233 /dev-python/griffe
parentdev-python/ensurepip-setuptools: Bump to 68.0.0 (diff)
downloadgentoo-f73b86cad9465f58a83cca2a064e18663b0d1372.tar.gz
gentoo-f73b86cad9465f58a83cca2a064e18663b0d1372.tar.bz2
gentoo-f73b86cad9465f58a83cca2a064e18663b0d1372.zip
dev-python/griffe: Bump to 0.29.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.29.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index a548febc158f..41ecdb270597 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.29.0.gh.tar.gz 157523 BLAKE2B 2854d6e30898e7aec9b6481215311956bcd9b24eb4b7cb36c11515f36a90467cabfc2cf9320bf4dcb44f04d8dd855cde97a749f7b51529cbfe5bd5e8e4391d9c SHA512 3367e48ac9337d180621fa694babc61dec445cc86b1555a65d14547c95aabda637ef72d86d3a1eb16fc736923876cda6c2ba51fa346551e5e134b490557d1459
+DIST griffe-0.29.1.gh.tar.gz 159747 BLAKE2B b998c2014a883ddb5c845b620ceba7a6edcaf7fbd7178ad356961cd1f0866927008d7ac16c1a0f13e886812ae706b3d117f8cd8e26e5f46999da44d843f0cd43 SHA512 f8405b2ace1dac83e451fa344d395f8e1733362409853b7952cbe10321eb13b7524cb96ba899559a08ebdbc57f997b7ee38ba8951730b288e4f87127e87b100b
diff --git a/dev-python/griffe/griffe-0.29.1.ebuild b/dev-python/griffe/griffe-0.29.1.ebuild
new file mode 100644
index 000000000000..2f7ad52e12f9
--- /dev/null
+++ b/dev-python/griffe/griffe-0.29.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}