summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-18 06:47:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-18 08:02:55 +0100
commit0aa647b9536c381b350bdbe00946899a5e196196 (patch)
tree23afc53452a2a66539c642e0042ce3dea7c77397 /dev-python/frozendict
parentdev-python/importlib_resources: Bump to 5.12.0 (diff)
downloadgentoo-0aa647b9536c381b350bdbe00946899a5e196196.tar.gz
gentoo-0aa647b9536c381b350bdbe00946899a5e196196.tar.bz2
gentoo-0aa647b9536c381b350bdbe00946899a5e196196.zip
dev-python/frozendict: Bump to 2.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest1
-rw-r--r--dev-python/frozendict/frozendict-2.3.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index 25b091d61a39..c791a05a85f7 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1 +1,2 @@
DIST frozendict-2.3.4.gh.tar.gz 307399 BLAKE2B ac6311182ed2ba4925a14a145b4d30a0241978f55ae7a81cebc534ede812ca77097f0f8c7eeb08e8cbd6240e036d3b5035bd3e9b284a55b638c93717e3a20258 SHA512 15acc4fceb5e2228ee3423d4a5b86c529e9bdcb7264f59139cbde6194983901a17da8036bebf53d7d8057ce52666031e90eb1ca358bfd374c651fd60743988dc
+DIST frozendict-2.3.5.gh.tar.gz 307566 BLAKE2B 8d8b7d483e248be5de3c6e689dbb7e8dc40f8a8112456308e6a0e633dee04640aa0bb43edcf07e2a9829b87b8d082aa0926581622372224e9636cca27eaeaef0 SHA512 9e3820f2a24f2362f1be82049df871449a5225a927efa7735a2e9320e3c9f835a4a0a99a0037a3366df55a5744b38e96b358a9cc624defa79f45a5bff4c3b61d
diff --git a/dev-python/frozendict/frozendict-2.3.5.ebuild b/dev-python/frozendict/frozendict-2.3.5.ebuild
new file mode 100644
index 000000000000..0cfb1f569acd
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+C_EXT_COMPAT=( python3.{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict/
+ https://pypi.org/project/frozendict/
+"
+SRC_URI="
+ https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x CIBUILDWHEEL=0
+ # This prevents the build system from ignoring build failures, sigh.
+ has "${EPYTHON}" "${C_EXT_COMPAT[@]}" && CIBUILDWHEEL=1
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ # skip tests of native extension for python versions where it is not available
+ if ! has "${EPYTHON}" "${C_EXT_COMPAT[@]}"; then
+ EPYTEST_IGNORE+=(
+ test/test_frozendict_c.py
+ test/test_frozendict_c_subclass.py
+ )
+ fi
+
+ rm -rf frozendict || die
+ epytest
+}