summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-13 06:32:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-13 06:54:52 +0200
commitbd4a910bfcf1caaa190ccd8b29ef92e2f1f8a4a8 (patch)
tree10d8d2c6376849ed387a0eacb70a1a57e7484630 /dev-python/fritzconnection
parentdev-python/Faker: Bump to 27.0.0 (diff)
downloadgentoo-bd4a910bfcf1caaa190ccd8b29ef92e2f1f8a4a8.tar.gz
gentoo-bd4a910bfcf1caaa190ccd8b29ef92e2f1f8a4a8.tar.bz2
gentoo-bd4a910bfcf1caaa190ccd8b29ef92e2f1f8a4a8.zip
dev-python/fritzconnection: Bump to 1.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fritzconnection')
-rw-r--r--dev-python/fritzconnection/Manifest1
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.14.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 4b89d1a4cf05..28b803cebf10 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1 +1,2 @@
DIST fritzconnection-1.13.2.gh.tar.gz 161752 BLAKE2B 9cd4af3ebaa3d617560ab833e4702b05d3bd6c8356242b4269506847760dad57c7f1d900d7da3092f4e07eb33c86f082c7d3dbc8179919b97422ad5eab78ef01 SHA512 c5e8566d2fde0b789269944df3c08f5cfb4b04ea4c91e5fc06eb97c6598f64b50b50778479948cb34c3a26d872e4d7c324a92791c3f593ec503a126d3b055062
+DIST fritzconnection-1.14.0.gh.tar.gz 165234 BLAKE2B 8a9350ad632eef353d08acd19560ffaed5d0cbfb073881f8892242b6616e1b830c84c7e9236280068278bac459a43f53c140a2f4d474ce9787a064530a8531b0 SHA512 99d002365d425ce459a3cfe9bbf48680639ccb1ef1cea65870a39e684c712abb8be16d10dad2c1a529c8b27c7b15dd9dad4a9eff38c975b1d8ff2fb15af72aa3
diff --git a/dev-python/fritzconnection/fritzconnection-1.14.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.14.0.ebuild
new file mode 100644
index 000000000000..58059b742c1b
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.14.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="
+ https://github.com/kbr/fritzconnection/
+ https://pypi.org/project/fritzconnection/
+"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="qrcode"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+ qrcode? (
+ dev-python/segno[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky (relies on time.sleep(0.01) magically being sufficient)
+ fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
+ )
+
+ if has_version "dev-python/segno[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # requires "QR Code detection" support in media-libs/opencv
+ # https://bugs.gentoo.org/917121
+ fritzconnection/tests/test_fritzwlan.py::test_get_wifi_qr_code
+ fritzconnection/tests/test_fritzwlan.py::test_helper_functions
+ fritzconnection/tests/test_fritzwlan.py::test_tools
+ )
+ fi
+
+ # "routertest" marks tests against live hardware
+ epytest -m "not routertest"
+}