summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-24 07:33:08 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-24 08:16:42 +0100
commitc98a09b2da11d0664c337387fc8c1bd7a07c5179 (patch)
tree35d1515ef32c7ae79227d8769db01a608d0def99 /dev-python/fonttools
parentdev-python/elasticsearch: Bump to 8.17.1 (diff)
downloadgentoo-c98a09b2da11d0664c337387fc8c1bd7a07c5179.tar.gz
gentoo-c98a09b2da11d0664c337387fc8c1bd7a07c5179.tar.bz2
gentoo-c98a09b2da11d0664c337387fc8c1bd7a07c5179.zip
dev-python/fonttools: Bump to 4.55.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.55.5.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index a17e46942ce2..53ece60b4629 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,3 +1,4 @@
DIST fonttools-4.55.0.gh.tar.gz 3886815 BLAKE2B ace8c3c1c866f4c181f685a44aeb69b8927bd7ddd452cb8268dc7c06183b372ddd88b64f7eba7ab3e4fa15ae359ffcf1d8144de4afbb1b4751173d75259eef3b SHA512 5f8a65687b5d66604eff5c518aaa51e5b2307e624e5397e5dc15b9489eeb6f300376ab6c70288f9bb7056532951f16085c5580f03b44de2a1d53f2860b573191
DIST fonttools-4.55.3.gh.tar.gz 3894793 BLAKE2B 0b02f5d5cac5b7cdd97d4c32310d02507604afbef12ecd59237fb0a5683170bd563f8e5c08f4f2ca057a8f952aafef7c6e087d072d96786ef8bea603521ce4ab SHA512 23257ebb9e890c0e5eb9776a9e82479a33859f4ab49015ee8434ae998814b7821b5226d14405667f9c67f03bbd0db41087d95dbc7650d812ed826db71929cab3
DIST fonttools-4.55.4.gh.tar.gz 3895558 BLAKE2B 9769f07c110f774bc597b6c4d63b502ff3d762136cb17ae8c3a97dc9826691944db88d62f858229cac827c9c76690a504c3f53416eecfb260b76dcf2c4dded40 SHA512 dd7aa3dc6650edcae4d72472f2530bea75a8e3f11b882712c241738f7f467346a1035dda73672cc82710fc09a40fc3ad1073238b9b1ef84bcaa6fa79a44ce468
+DIST fonttools-4.55.5.gh.tar.gz 3897134 BLAKE2B 7e7cd6f172e34488a095ff55341a9f6a075ad5ccd4f375d052ab3a586244923464d21a93c75af985ae81cc85bb897f8a1731fe7eabcfdf0b1f2c6bb9eed9e36f SHA512 fb2d4fb67c7778ebcb166f39651e3fceb8986844dee2ce711554e7bf0d160c458110352e922c8faf85a5514f6fc56762f82d037b0df44c3cb8b17191b827a6d9
diff --git a/dev-python/fonttools/fonttools-4.55.5.ebuild b/dev-python/fonttools/fonttools-4.55.5.ebuild
new file mode 100644
index 000000000000..0adf50c35de4
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.55.5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/munkres[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test
+ Tests/ttLib/woff2_test.py::WOFF2ReaderTest::test_get_normal_tables
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest \
+ -p rerunfailures --reruns=5 \
+ Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}