summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:18 +0200
commit113c06a80204e7cf68e41ba95667ecd2d5830e29 (patch)
treed3e4aa3d467fcec481f65f8933c3ca86f197393e /dev-python/flask-restful
parentdev-python/flask-babelex: Remove redundant versions (diff)
downloadgentoo-113c06a80204e7cf68e41ba95667ecd2d5830e29.tar.gz
gentoo-113c06a80204e7cf68e41ba95667ecd2d5830e29.tar.bz2
gentoo-113c06a80204e7cf68e41ba95667ecd2d5830e29.zip
dev-python/flask-restful: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-restful')
-rw-r--r--dev-python/flask-restful/Manifest1
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.7.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/flask-restful/Manifest b/dev-python/flask-restful/Manifest
index 8e2a4ed18038..57f2e49019e5 100644
--- a/dev-python/flask-restful/Manifest
+++ b/dev-python/flask-restful/Manifest
@@ -1,2 +1 @@
-DIST flask-restful-0.3.7.tar.gz 114238 BLAKE2B ec960f060b3a1a36e538606d710a57e9d9fb3b1c2c1ee1874c5f7592e9ad8a9a2af4716f820f27ec1a9e55fcb0505ca711c6e045e6cb0ef8c9c64de339871710 SHA512 1d1d066dec5f39af3197b680f791d83df686602b703efe874ea0e81d7f3b65f605dbdb63f84fdd07e469c6824d52571e195ae70f58e1543b53f13a81e1cd8543
DIST flask-restful-0.3.8.tar.gz 114588 BLAKE2B a18eac613300102bb5a5ca78cea1e6f81f3de21d8bd2e6c72f2f1a559e8b4228175cc7d372b68f131267cd8bc759e354e5782e527d1e992579210348cd2b78dd SHA512 15172114fcedc2f4286cf5f583d95e42c8c8ce6553f9a44e57124f2b1417bf9f094dcb5154a6933ebebc8022f39d4d7969d29d38576111f9d5b45f630b36a66c
diff --git a/dev-python/flask-restful/flask-restful-0.3.7.ebuild b/dev-python/flask-restful/flask-restful-0.3.7.ebuild
deleted file mode 100644
index 3b9a6bd9d809..000000000000
--- a/dev-python/flask-restful/flask-restful-0.3.7.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple framework for creating REST APIs"
-HOMEPAGE="https://flask-restful.readthedocs.io/en/latest/ https://github.com/twilio/flask-restful/"
-SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
- >=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/sphinx[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_compile_all() {
- cd docs || die
- emake man $(usex doc html "")
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && dodoc -r examples
- local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
-
- doman docs/_build/man/*
- distutils-r1_python_install_all
-}