summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-21 21:46:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-21 21:46:43 +0300
commit8b7081ee2f22d11780bc31db5f6c775b5a370fbc (patch)
treedbc232aeedb97984a63c12a4c5d74e14f62893cf /dev-python/fixtures
parentdev-python/routes: drop 2.5.1 (diff)
downloadgentoo-8b7081ee2f22d11780bc31db5f6c775b5a370fbc.tar.gz
gentoo-8b7081ee2f22d11780bc31db5f6c775b5a370fbc.tar.bz2
gentoo-8b7081ee2f22d11780bc31db5f6c775b5a370fbc.zip
dev-python/fixtures: drop 3.0.0-r1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/Manifest1
-rw-r--r--dev-python/fixtures/fixtures-3.0.0-r1.ebuild38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/fixtures/Manifest b/dev-python/fixtures/Manifest
index 039cc343e28e..717b04dcbdca 100644
--- a/dev-python/fixtures/Manifest
+++ b/dev-python/fixtures/Manifest
@@ -1,2 +1 @@
-DIST fixtures-3.0.0.tar.gz 56629 BLAKE2B 949c67c428f5e5ca0afc2f875dd4e2a212922415762a2528c185794e4ae2b74d32873aaf7132d97dec95a681bb4d87d85b11a39c43c64cd531dd4bf2fce75f87 SHA512 e52ba864c42d15a8baa60583761006b2dd78e3cd5f3f043f5702346aef428b933d62e8fa5889b7cb4196e4072acc5df3b7ffa39702a1b782887bdc109299b695
DIST fixtures-4.0.0.tar.gz 56786 BLAKE2B 7fa8916d3e384a47c967b51ffeebb81c50c4be7432601aa94f220b6ae32ed189f16750cb126c2925995c2e945684c48041014a97902145343527e8856125b61a SHA512 dcd67c3df9efc16f2a21b6d2917a5b7e45ecc09d1ddbd1de98a5b4b717ea7da0fc82e1054f494255b419a792e841145110c77a1772444f4019fc02e9917c5b80
diff --git a/dev-python/fixtures/fixtures-3.0.0-r1.ebuild b/dev-python/fixtures/fixtures-3.0.0-r1.ebuild
deleted file mode 100644
index 2f2791853de5..000000000000
--- a/dev-python/fixtures/fixtures-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
-HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.org/project/fixtures/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# nose not listed but provides coverage output of tests
-# run of test files by python lacks any output except on fail
-RDEPEND="
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-src_prepare() {
- # broken on py3.9
- # https://github.com/testing-cabal/fixtures/issues/44
- sed -i -e 's:test_patch_classmethod_with:_&:' \
- fixtures/tests/_fixtures/test_monkeypatch.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- emake check
-}