summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-26 22:16:54 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-26 22:18:10 +0800
commite7f7ce9c09c4c11e9d1a136fcfb42b2e06c7bd73 (patch)
tree445fa394c0101e334ad9b184783be006a3fab9b6 /dev-python/elasticsearch-py
parentnet-misc/ipv6calc: drop maintainer wrt bug #564134 (diff)
downloadgentoo-e7f7ce9c09c4c11e9d1a136fcfb42b2e06c7bd73.tar.gz
gentoo-e7f7ce9c09c4c11e9d1a136fcfb42b2e06c7bd73.tar.bz2
gentoo-e7f7ce9c09c4c11e9d1a136fcfb42b2e06c7bd73.zip
dev-python/elasticsearch-py: follow up edit to doc, man page install
depend on sphinx unconditionaly, drop un-neededsphinx_rtd_theme, rename the generated man pages to elasticsearch-py.1 for man pages, patch by proxy maintainer Gentoo bug: #564108 Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/elasticsearch-py')
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild
index 482bc302e46b..2f6b7a5af62e 100644
--- a/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild
+++ b/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild
@@ -24,9 +24,7 @@ RDEPEND=">=dev-python/urllib3-1.8[${PYTHON_USEDEP}]
<dev-python/urllib3-2.0[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
test? ( ${RDEPEND}
>=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
<dev-python/requests-3.0.0[${PYTHON_USEDEP}]
@@ -37,6 +35,13 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/nosexcover[${PYTHON_USEDEP}]
|| ( virtual/jre:1.8 virtual/jre:1.7 ) )"
+python_prepare_all() {
+ # rename manpage to elasticsearch-py
+ sed -i "s@('index', 'elasticsearch'@('index', 'elasticsearch-py'@g" docs/conf.py
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
ES_PORT="25124"
@@ -80,14 +85,12 @@ python_test() {
python_compile_all() {
cd docs || die
- use doc && emake man html
+ emake man $(usex doc html "")
}
python_install_all() {
- if use doc; then
- export HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
- fi
+ use doc && HTML_DOCS=( docs/_build/html/. )
use examples && local EXAMPLES=( example/. )
+ doman docs/_build/man/*
distutils-r1_python_install_all
}